Skip to content

systeminformation (npm)

Advisories
18
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 5.33.16 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install systeminformation@5.33.16
yarn
yarn add systeminformation@5.33.16
pnpm
pnpm add systeminformation@5.33.16

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-3f7j-7jwc-fxfj
systeminformation vulnerable to Windows command injection in services() through Unicode quotation marks
High
EPSS 0.14%
< 5.33.16
5.33.16
GHSA-4vjg-vx72-qq4g
systeminformation has path traversal in Linux networkStats() that allows symlink-based file disclosure outside /sys/class/net
Low
EPSS 0.13%
< 5.33.14
5.33.14
GHSA-7648-jmwf-vw7j
systeminformation has prototype pollution in `networkStats()` via the interface name
Medium
EPSS 0.29%
< 5.33.13
5.33.13
GHSA-5xpp-75jx-m839
systeminformation: OS command injection in networkInterfaces() via interfaces(5) source-directive path on Linux
High
EPSS 2.18%
< 5.31.7
5.31.7
GHSA-hvx9-hwr7-wjj9
Systeminformation vulnerable to Linux command injection in networkInterfaces() via unsanitized NetworkManager connection profile name
High
EPSS 0.92%
>= 4.17.0, < 5.31.6
5.31.6
GHSA-5vv4-hvf7-2h46
Command Injection via Unsanitized `locate` Output in `versions()` — systeminformation
High
EPSS 1.28%
< 5.31.0
5.31.0
GHSA-9c88-49p5-5ggf
Systeminformation has a Command Injection via unsanitized interface parameter in wifi.js retry path
High
EPSS 1.37%
< 5.30.8
5.30.8
GHSA-wphj-fx3q-84ch
systeminformation has a Command Injection vulnerability in fsSize() function on Windows
High
EPSS 12.99%
< 5.27.14
5.27.14
GHSA-cvv5-9h9w-qp2m
Systeminformation has command injection vulnerability in getWindowsIEEE8021x (SSID)
High
EPSS 0.70%
< 5.23.7
5.23.7
GHSA-gx6r-qc2v-3p3v
systeminformation SSID Command Injection Vulnerability
Critical
EPSS 2.22%
>= 5.0.0, < 5.21.7
5.21.7
GHSA-8j36-q8x7-pm6q
OS Command Injection in systeminformation
High
EPSS 2.42%
< 4.30.2
4.30.2
GHSA-jff2-qjw8-5476
Command Injection Vulnerability in systeminformation
High
EPSS 1.85%
< 5.6.4
5.6.4
CVE-2021-21315
Command Injection Vulnerability
Known exploited
High
EPSS 90.67%
< 5.3.1
5.3.1
CVE-2021-21315
Command Injection Vulnerability
Known exploited
High
EPSS 90.67%
< 5.3.1
5.3.1
GHSA-m57p-p67h-mq74
Command Injection Vulnerability in systeminformation
Medium
EPSS 2.74%
< 4.31.1
4.31.1
GHSA-4v2w-h9jm-mqjg
Prototype Pollution in systeminformation
High
EPSS 2.23%
< 4.30.5
4.30.5
GHSA-fj59-f6c3-3vw4
Command Injection in systeminformation
Medium
EPSS 1.41%
< 4.26.2
4.26.2
GHSA-94xh-2fmc-xf5j
systeminformation command injection vulnerability
High
EPSS 6.75%
< 4.27.11
4.27.11
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor