sequelize (npm)
Advisories
22
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 6.37.8 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install sequelize@6.37.8yarn
yarn add sequelize@6.37.8pnpm
pnpm add sequelize@6.37.8Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-v8fg-2rw7-q452 Sequelize: SQL Injection (Oracle DB) |
Critical EPSS 0.54% |
< 6.37.4 | 6.37.4 |
| GHSA-6457-6jrx-69cr Sequelize v6 Vulnerable to SQL Injection via JSON Column Cast Type |
High EPSS 0.45% |
>= 6.0.0-beta.1, < 6.37.8 | 6.37.8 |
| GHSA-wrh9-cjv3-2hpw Sequelize vulnerable to SQL Injection via replacements |
Critical EPSS 1.44% |
< 6.19.1 | 6.19.1 |
| GHSA-8mwq-mj73-qv68 Duplicate advisory: Sequelize vulnerable to Improper Filtering of Special Elements Withdrawn |
Critical | < 6.29.0 | 6.29.0 |
| GHSA-8c25-f3mj-v6h8 Sequelize information disclosure vulnerability |
High EPSS 0.58% |
< 6.28.1 | 6.28.1 |
| GHSA-vqfx-gj96-3w95 Unsafe fall-through in getWhereConditions |
High EPSS 0.81% |
< 6.28.1 | 6.28.1 |
| GHSA-f598-mfpv-gmfx Sequelize - Default support for “raw attributes” when using parentheses |
Critical EPSS 0.83% |
< 6.29.0 | 6.29.0 |
| GHSA-fw4p-36j9-rrj3 Denial of Service in sequelize |
Medium | < 4.44.4 | 4.44.4 |
| GHSA-5v9h-q3gj-c32x SQL Injection via GeoJSON in sequelize |
Critical | >= 3.4.0, < 3.23.6 | 3.23.6 |
| GHSA-2598-2f59-rmhq SQL Injection in sequelize |
Critical EPSS 1.23% |
< 3.35.1 | 3.35.1 |
| GHSA-j9xp-92vc-559j SQL Injection in sequelize |
Critical EPSS 1.31% |
>= 5.0.0, < 5.8.11 | 5.8.11 |
| GHSA-j9xp-92vc-559j SQL Injection in sequelize |
Critical EPSS 1.31% |
>= 4.0.0, < 4.44.3 | 4.44.3 |
| GHSA-j9xp-92vc-559j SQL Injection in sequelize |
Critical EPSS 1.31% |
< 3.35.1 | 3.35.1 |
| GHSA-m9jw-237r-gvfv SQL Injection in sequelize |
Critical EPSS 1.46% |
>= 5.0.0, < 5.15.1 | 5.15.1 |
| GHSA-m9jw-237r-gvfv SQL Injection in sequelize |
Critical EPSS 1.46% |
< 4.44.3 | 4.44.3 |
| GHSA-wfp9-vr4j-f49j NoSQL Injection in sequelize |
High | < 4.12.0 | 4.12.0 |
| GHSA-2777-2vq8-c4v4 SQL Injection in sequelize |
High EPSS 1.82% |
>= 5.0.0, < 5.3.0 | 5.3.0 |
| GHSA-98pq-pmw9-4gpm SQL Injection in sequelize |
High EPSS 1.88% |
< 3.17.0 | 3.17.0 |
| GHSA-2v7q-2xqx-f4q5 Potential SQL Injection in sequelize |
High EPSS 1.26% |
< 3.0.0 | 3.0.0 |
| GHSA-x2jc-pwfj-h9p3 SQL Injection in sequelize |
Medium EPSS 1.88% |
< 1.7.0 | 1.7.0 |
| GHSA-9c2p-jw8p-f84v SQL Injection in sequelize |
High EPSS 1.32% |
< 3.20.0 | 3.20.0 |
| GHSA-xqg8-cv3h-xppv SQL Injection in sequelize |
High EPSS 2.11% |
< 2.0.0-rc8 | 2.0.0-rc8 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor