Skip to content

rollup (npm)

Next-generation ES module bundler

Advisories
9
Latest version
4.65.1
Released Oct 26, 2026
License
MIT
OpenSSF Scorecard
5.3 / 10

How to fix

Upgrading to 4.59.0 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install rollup@4.65.1
yarn
yarn add rollup@4.65.1
pnpm
pnpm add rollup@4.65.1

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-mw96-cpmx-2vgc
Rollup 4 has Arbitrary File Write via Path Traversal
High
EPSS 1.65%
>= 4.0.0, < 4.59.0
4.59.0
GHSA-mw96-cpmx-2vgc
Rollup 4 has Arbitrary File Write via Path Traversal
High
EPSS 1.65%
>= 4.0.0, < 4.59.0
4.59.0
GHSA-mw96-cpmx-2vgc
Rollup 4 has Arbitrary File Write via Path Traversal
High
EPSS 1.65%
< 2.80.0
2.80.0
GHSA-mw96-cpmx-2vgc
Rollup 4 has Arbitrary File Write via Path Traversal
High
EPSS 1.65%
>= 3.0.0, < 3.30.0
3.30.0
GHSA-mw96-cpmx-2vgc
Rollup 4 has Arbitrary File Write via Path Traversal
High
EPSS 1.65%
< 2.80.0
2.80.0
GHSA-mw96-cpmx-2vgc
Rollup 4 has Arbitrary File Write via Path Traversal
High
EPSS 1.65%
>= 3.0.0, < 3.30.0
3.30.0
GHSA-gcx4-mw62-g8wm
DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS
Medium
EPSS 0.74%
>= 4.0.0, < 4.22.4
4.22.4
GHSA-gcx4-mw62-g8wm
DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS
Medium
EPSS 0.74%
< 2.79.2
2.79.2
GHSA-gcx4-mw62-g8wm
DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS
Medium
EPSS 0.74%
>= 3.0.0, < 3.29.5
3.29.5

Source: git+https://github.com/rollup/rollup.git

Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor