open-webui (npm)
Advisories
6
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 0.9.0 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install open-webui@0.9.0yarn
yarn add open-webui@0.9.0pnpm
pnpm add open-webui@0.9.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-gf5m-wcrh-7928 open-webui Vulnerable to Stored XSS via Model Description |
High EPSS 0.31% |
< 0.9.0 | 0.9.0 |
| GHSA-cm35-v4vp-5xvx Open WebUI Affected by an External Model Server (Direct Connections) Code Injection via SSE Events |
High EPSS 7.23% |
< 0.6.35 | 0.6.35 |
| GHSA-w7xj-8fx7-wfch Open WebUI vulnerable to Stored DOM XSS via prompts when 'Insert Prompt as Rich Text' is enabled resulting in ATO/RCE |
Medium EPSS 0.49% |
< 0.6.35 | 0.6.35 |
| GHSA-5ccf-884p-4jjq Open WebUI Unauthenticated Multipart Boundary Denial of Service (DoS) Vulnerability |
High | <= 0.3.21 | No fix yet |
| GHSA-chf7-q7m5-fq92 Open WebUI Uncontrolled Resource Consumption vulnerability |
High | <= 0.3.32 | No fix yet |
| GHSA-g3mx-83mp-3rwc Open WebUI Uncontrolled Resource Consumption vulnerability |
High | <= 0.3.32 | No fix yet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor