lodash-amd (npm)
Advisories
10
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 4.18.0 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install lodash-amd@4.18.0yarn
yarn add lodash-amd@4.18.0pnpm
pnpm add lodash-amd@4.18.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-r5fr-rjxr-66jc lodash vulnerable to Code Injection via `_.template` imports key names |
Critical EPSS 2.81% |
>= 4.0.0, < 4.18.0 | 4.18.0 |
| GHSA-r5fr-rjxr-66jc lodash vulnerable to Code Injection via `_.template` imports key names |
Critical EPSS 2.81% |
>= 4.0.0, <= 4.17.23 | No fix yet |
| GHSA-f23m-r3pf-42rh lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit` |
Medium EPSS 0.34% |
< 4.18.0 | 4.18.0 |
| GHSA-f23m-r3pf-42rh lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit` |
Medium EPSS 0.34% |
<= 4.17.23 | No fix yet |
| GHSA-xxjr-mmjv-4gpg Lodash has Prototype Pollution Vulnerability in `_.unset` and `_.omit` functions |
Medium EPSS 1.82% |
>= 4.0.0, <= 4.17.22 | No fix yet |
| GHSA-xxjr-mmjv-4gpg Lodash has Prototype Pollution Vulnerability in `_.unset` and `_.omit` functions |
Medium EPSS 1.82% |
>= 4.0.0, < 4.17.23 | 4.17.23 |
| GHSA-x5rq-j2xg-h7qm Regular Expression Denial of Service (ReDoS) in lodash |
Medium EPSS 3.04% |
>= 4.7.0, < 4.17.11 | 4.17.11 |
| GHSA-x5rq-j2xg-h7qm Regular Expression Denial of Service (ReDoS) in lodash |
Medium EPSS 3.04% |
>= 4.7.0, < 4.17.11 | 4.17.11 |
| GHSA-jf85-cpcp-j695 Prototype Pollution in lodash |
Critical EPSS 5.01% |
< 4.17.13 | 4.17.13 |
| GHSA-jf85-cpcp-j695 Prototype Pollution in lodash |
Critical EPSS 5.01% |
< 4.17.13 | 4.17.13 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor