Skip to content

eslint-plugin-prettier (npm)

Advisories
2
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 4.2.4 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install eslint-plugin-prettier@4.2.4
yarn
yarn add eslint-plugin-prettier@4.2.4
pnpm
pnpm add eslint-plugin-prettier@4.2.4

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-f29h-pxvx-f335
eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code
Known exploited
High
EPSS 5.12%
>= 4.2.2, < 4.2.4
4.2.4
GHSA-f29h-pxvx-f335
eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code
Known exploited
High
EPSS 5.12%
>= 4.2.2, <= 4.2.3
No fix yet
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor