Skip to content

diff (npm)

A javascript text differencing implementation.

Advisories
9
Latest version
9.0.0
Released Apr 13, 2026
License
BSD-3-Clause
OpenSSF Scorecard
3.2 / 10

How to fix

Upgrading to 8.0.3 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install diff@9.0.0
yarn
yarn add diff@9.0.0
pnpm
pnpm add diff@9.0.0

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
< 3.5.1
3.5.1
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
>= 6.0.0, < 8.0.3
8.0.3
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
>= 5.0.0, < 5.2.2
5.2.2
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
>= 4.0.0, < 4.0.4
4.0.4
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
< 3.5.1
3.5.1
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
>= 6.0.0, < 8.0.3
8.0.3
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
>= 5.0.0, < 5.2.2
5.2.2
GHSA-73rr-hh4g-fpgx
jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Low
EPSS 0.62%
>= 4.0.0, < 4.0.4
4.0.4
GHSA-h6ch-v84p-w6p9
Regular Expression Denial of Service (ReDoS)
High
< 3.5.0
3.5.0

Source: https://github.com/kpdecker/jsdiff.git

Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor