Skip to content

compression (npm)

Node.js compression middleware

Advisories
2
Latest version
1.8.2
Released Sep 11, 2026
License
MIT
OpenSSF Scorecard
6.5 / 10

How to fix

Upgrading to 1.8.2 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install compression@1.8.2
yarn
yarn add compression@1.8.2
pnpm
pnpm add compression@1.8.2

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-vc2v-76pw-4v95
compression vulnerable to Denial of Service via memory leak on premature response close
High
EPSS 0.48%
< 1.8.2
1.8.2
GHSA-vc2v-76pw-4v95
compression vulnerable to Denial of Service via memory leak on premature response close
High
EPSS 0.48%
< 1.8.2
1.8.2

Source: git+https://github.com/expressjs/compression.git

Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor