angular (npm)
Advisories
15
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.8.0 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install angular@1.8.0yarn
yarn add angular@1.8.0pnpm
pnpm add angular@1.8.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-7x27-g8rg-x87w Angular's deprecated package has a Cross-Site Scripting issue |
High EPSS 0.40% |
>= 1.2.0-rc.3, <= 1.8.3 | No fix yet |
| GHSA-j58c-ww9w-pwp5 AngularJS improperly sanitizes SVG elements |
Medium EPSS 0.41% |
<= 1.8.3 | No fix yet |
| GHSA-mqm9-c95h-x2p6 AngularJS allows attackers to bypass common image source restrictions |
Medium EPSS 0.64% |
<= 1.8.3 | No fix yet |
| GHSA-m9gf-397r-hwpg AngularJS allows attackers to bypass common image source restrictions |
Medium EPSS 0.61% |
>= 1.3.0-rc.4, <= 1.8.3 | No fix yet |
| GHSA-4w4v-5hc9-xrr2 angular vulnerable to super-linear runtime due to backtracking |
High EPSS 1.89% |
>= 1.3.0, <= 1.8.3 | No fix yet |
| GHSA-qwqh-hm9m-p5hr angular vulnerable to regular expression denial of service via the <input type="url"> element |
Medium EPSS 1.70% |
<= 1.8.3 | No fix yet |
| GHSA-2qqx-w9hr-q5gx angular vulnerable to regular expression denial of service via the $resource service |
Medium EPSS 1.70% |
<= 1.8.3 | No fix yet |
| GHSA-2vrf-hf26-jrp5 angular vulnerable to regular expression denial of service via the angular.copy() utility |
Medium EPSS 1.70% |
<= 1.8.3 | No fix yet |
| GHSA-prc3-vjfx-vhm9 Angular (deprecated package) Cross-site Scripting |
Medium EPSS 7.68% |
<= 1.8.3 | No fix yet |
| GHSA-m2h2-264f-f486 angular vulnerable to regular expression denial of service (ReDoS) |
Medium EPSS 4.93% |
>= 1.7.0 | No fix yet |
| GHSA-5cp4-xmrw-59wf XSS via JQLite DOM manipulation functions in AngularJS |
Medium | < 1.8.0 | 1.8.0 |
| GHSA-mhp6-pxh8-r675 Angular vulnerable to Cross-site Scripting |
Medium EPSS 1.93% |
< 1.8.0 | 1.8.0 |
| GHSA-r5fx-8r73-v86c AngularJS Cross-site Scripting due to failure to sanitize `xlink.href` attributes |
Medium EPSS 1.20% |
< 1.5.0-beta.1 | 1.5.0-beta.1 |
| GHSA-89mq-4x47-5v83 angular Prototype Pollution vulnerability |
High EPSS 1.98% |
< 1.7.9 | 1.7.9 |
| GHSA-28hp-fgcr-2r4h Cross-Site Scripting via JSONP |
Medium | < 1.6.0 | 1.6.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor