Skip to content

@tanstack/valibot-adapter (npm)

Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 1.166.16 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install @tanstack/valibot-adapter@1.166.16
yarn
yarn add @tanstack/valibot-adapter@1.166.16
pnpm
pnpm add @tanstack/valibot-adapter@1.166.16

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-g7cv-rxg3-hmpx
Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys
Known exploited
Critical
EPSS 3.28%
>= 1.166.12, < 1.166.16
1.166.16
GHSA-g7cv-rxg3-hmpx
Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys
Known exploited
Critical
EPSS 3.28%
>= 1.166.15, < 1.166.16
1.166.16
GHSA-g7cv-rxg3-hmpx
Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys
Known exploited
Critical
EPSS 3.28%
No fix yet
GHSA-g7cv-rxg3-hmpx
Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys
Known exploited
Critical
EPSS 3.28%
No fix yet
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor