@tanstack/router-plugin (npm)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.167.42 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install @tanstack/router-plugin@1.167.42yarn
yarn add @tanstack/router-plugin@1.167.42pnpm
pnpm add @tanstack/router-plugin@1.167.42Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-g7cv-rxg3-hmpx Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys Known exploited |
Critical EPSS 3.28% |
>= 1.167.38, < 1.167.42 | 1.167.42 |
| GHSA-g7cv-rxg3-hmpx Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys Known exploited |
Critical EPSS 3.28% |
>= 1.167.41, < 1.167.42 | 1.167.42 |
| GHSA-g7cv-rxg3-hmpx Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys Known exploited |
Critical EPSS 3.28% |
No fix yet | |
| GHSA-g7cv-rxg3-hmpx Malware in @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys Known exploited |
Critical EPSS 3.28% |
No fix yet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor