Skip to content

@sveltejs/adapter-node (npm)

Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 5.5.1 or later clears every advisory below that has a fix.

Upgrade commands
npm
npm install @sveltejs/adapter-node@5.5.1
yarn
yarn add @sveltejs/adapter-node@5.5.1
pnpm
pnpm add @sveltejs/adapter-node@5.5.1

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-j62c-4x62-9r35
SvelteKit is vulnerable to denial of service and possible SSRF when using prerendering
Critical
EPSS 0.52%
>= 5.4.1, < 5.5.1
5.5.1
GHSA-g5m6-hxpp-fc49
Sending a GET or HEAD request with a body crashes SvelteKit
High
EPSS 0.76%
>= 2.0.0, < 2.1.2
2.1.2
GHSA-g5m6-hxpp-fc49
Sending a GET or HEAD request with a body crashes SvelteKit
High
EPSS 0.76%
>= 3.0.0, < 3.0.3
3.0.3
GHSA-g5m6-hxpp-fc49
Sending a GET or HEAD request with a body crashes SvelteKit
High
EPSS 0.76%
>= 4.0.0, < 4.0.1
4.0.1
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor