@sequelize/core (npm)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 7.0.0-alpha.20 or later clears every advisory below that has a fix.
Upgrade commands
npm
npm install @sequelize/core@7.0.0-alpha.20yarn
yarn add @sequelize/core@7.0.0-alpha.20pnpm
pnpm add @sequelize/core@7.0.0-alpha.20Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-8mwq-mj73-qv68 Duplicate advisory: Sequelize vulnerable to Improper Filtering of Special Elements Withdrawn |
Critical | < 7.0.0-alpha.20 | 7.0.0-alpha.20 |
| GHSA-8c25-f3mj-v6h8 Sequelize information disclosure vulnerability |
High EPSS 0.58% |
< 7.0.0-alpha.20 | 7.0.0-alpha.20 |
| GHSA-vqfx-gj96-3w95 Unsafe fall-through in getWhereConditions |
High EPSS 0.81% |
< 7.0.0-alpha.20 | 7.0.0-alpha.20 |
| GHSA-f598-mfpv-gmfx Sequelize - Default support for “raw attributes” when using parentheses |
Critical EPSS 0.83% |
< 7.0.0-alpha.20 | 7.0.0-alpha.20 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor