libpulse-binding (crates.io)
Advisories
11
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.6.0 or later clears every advisory below that has a fix.
Upgrade commands
cargo
cargo update -p libpulse-binding --precise 2.6.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| RUSTSEC-2020-0055 Please see RUSTSEC-2018-0020 Withdrawn |
Not rated yet | >= 0.0.0-0, < 0.0.1-0 | 0.0.1-0 |
| GHSA-wcxc-jf6c-8rx9 Duplicate Advisory: Uncaught Exception in libpulse-binding |
High EPSS 1.22% |
>= 0.0.0-0, < 2.6.0 | 2.6.0 |
| GHSA-wcxc-jf6c-8rx9 Duplicate Advisory: Uncaught Exception in libpulse-binding |
High EPSS 1.22% |
< 2.6.0 | 2.6.0 |
| GHSA-wcxc-jf6c-8rx9 Duplicate Advisory: Uncaught Exception in libpulse-binding |
High EPSS 1.22% |
< 2.6.0 | 2.6.0 |
| GHSA-6gvc-4jvj-pwq4 Duplicate Advisory: Use after free in libpulse-binding |
Medium EPSS 1.00% |
>= 1.0.5, < 2.5.0 | 2.5.0 |
| GHSA-6gvc-4jvj-pwq4 Duplicate Advisory: Use after free in libpulse-binding |
Medium EPSS 1.00% |
>= 1.0.5, < 2.5.0 | 2.5.0 |
| GHSA-6gvc-4jvj-pwq4 Duplicate Advisory: Use after free in libpulse-binding |
Medium EPSS 1.00% |
>= 1.0.5, < 2.5.0 | 2.5.0 |
| GHSA-jqpv-jm4m-86j9 Use after free in libpulse-binding |
High EPSS 1.41% |
>= 0.0.0-0, < 1.2.1 | 1.2.1 |
| GHSA-jqpv-jm4m-86j9 Use after free in libpulse-binding |
High EPSS 1.41% |
< 1.2.1 | 1.2.1 |
| GHSA-jqpv-jm4m-86j9 Use after free in libpulse-binding |
High EPSS 1.41% |
< 1.2.1 | 1.2.1 |
| GHSA-jqpv-jm4m-86j9 Use after free in libpulse-binding |
High EPSS 1.41% |
< 1.2.1 | 1.2.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor