h2 (crates.io)
Advisories
9
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 0.4.16 or later clears every advisory below that has a fix.
Upgrade commands
cargo
cargo update -p h2 --precise 0.4.16Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| RUSTSEC-2026-0258 h2 unbounded empty DATA frames |
Not rated yet | >= 0.0.0-0, < 0.4.16 | 0.4.16 |
| GHSA-q6cp-qfwq-4gcv h2 servers vulnerable to degradation of service with CONTINUATION Flood |
Medium | < 0.3.26 | 0.3.26 |
| GHSA-q6cp-qfwq-4gcv h2 servers vulnerable to degradation of service with CONTINUATION Flood |
Medium | >= 0.0.0-0, < 0.3.26>= 0.4.0-0, < 0.4.4 | 0.3.260.4.4 |
| GHSA-q6cp-qfwq-4gcv h2 servers vulnerable to degradation of service with CONTINUATION Flood |
Medium | >= 0.4.0, < 0.4.4 | 0.4.4 |
| GHSA-8r5v-vm4m-4g25 Resource exhaustion vulnerability in h2 may lead to Denial of Service (DoS) |
High EPSS 82.81% |
>= 0.4.0, < 0.4.2 | 0.4.2 |
| GHSA-8r5v-vm4m-4g25 Resource exhaustion vulnerability in h2 may lead to Denial of Service (DoS) |
High EPSS 82.81% |
< 0.3.24 | 0.3.24 |
| GHSA-8r5v-vm4m-4g25 Resource exhaustion vulnerability in h2 may lead to Denial of Service (DoS) |
High EPSS 82.81% |
>= 0.0.0-0, < 0.3.24>= 0.4.0-0, < 0.4.2 | 0.3.240.4.2 |
| GHSA-f8vr-r385-rh5r h2 vulnerable to denial of service |
High EPSS 1.12% |
< 0.3.17 | 0.3.17 |
| GHSA-f8vr-r385-rh5r h2 vulnerable to denial of service |
High EPSS 1.12% |
>= 0.0.0-0, < 0.3.17 | 0.3.17 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor