deepseek-tui-cli (crates.io)
Advisories
2
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 0.8.23 or later clears every advisory below that has a fix.
Upgrade commands
cargo
cargo update -p deepseek-tui-cli --precise 0.8.23Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-wx44-2q6h-j6p8 DeepSeek TUI: run_tests Tool Enables RCE via Malicious Repository Without Approval |
Critical EPSS 0.57% |
>= 0.3.0, < 0.8.23 | 0.8.23 |
| GHSA-96ff-gc8g-wpvg DeepSeek TUI has SSRF via HTTP Redirect Bypass in fetch_url Tool |
High EPSS 0.28% |
< 0.8.22 | 0.8.22 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor