Skip to content

cosmwasm-vm (crates.io)

Advisories
19
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.2.1 or later clears every advisory below that has a fix.

Upgrade commands
cargo
cargo update -p cosmwasm-vm --precise 2.2.1

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-mx2j-7cmv-353c
wasmvm: Malicious smart contract can slow down block production
Medium
< 1.5.10
1.5.10
GHSA-mx2j-7cmv-353c
wasmvm: Malicious smart contract can slow down block production
Medium
>= 2.2.0, < 2.2.1
2.2.1
GHSA-mx2j-7cmv-353c
wasmvm: Malicious smart contract can slow down block production
Medium
>= 2.1.0, < 2.1.6
2.1.6
GHSA-mx2j-7cmv-353c
wasmvm: Malicious smart contract can slow down block production
Medium
>= 2.0.0, < 2.0.9
2.0.9
GHSA-2q97-m5rc-p3gp
CosmWasm VM Incorrect metering
Medium
>= 2.1.0, < 2.1.4
2.1.4
GHSA-2q97-m5rc-p3gp
CosmWasm VM Incorrect metering
Medium
< 1.5.8
1.5.8
GHSA-2q97-m5rc-p3gp
CosmWasm VM Incorrect metering
Medium
>= 2.0.0, < 2.0.7
2.0.7
GHSA-vmqh-5232-v43r
Panic in wasmvm can slow down block production
Medium
< 1.5.8
1.5.8
GHSA-vmqh-5232-v43r
Panic in wasmvm can slow down block production
Medium
>= 2.1.0, < 2.1.4
2.1.4
GHSA-vmqh-5232-v43r
Panic in wasmvm can slow down block production
Medium
>= 2.0.0, < 2.0.7
2.0.7
GHSA-75qh-gg76-p2w4
CWA-2023-004: Excessive number of function parameters in compiled Wasm
Medium
< 1.2.8
1.2.8
GHSA-75qh-gg76-p2w4
CWA-2023-004: Excessive number of function parameters in compiled Wasm
Medium
>= 1.3.0, < 1.3.4
1.3.4
GHSA-75qh-gg76-p2w4
CWA-2023-004: Excessive number of function parameters in compiled Wasm
Medium
>= 1.4.0, < 1.4.2
1.4.2
GHSA-75qh-gg76-p2w4
CWA-2023-004: Excessive number of function parameters in compiled Wasm
Medium
>= 1.5.0, < 1.5.1
1.5.1
GHSA-75qh-gg76-p2w4
CWA-2023-004: Excessive number of function parameters in compiled Wasm
Medium
>= 0.0.0-0, < 1.2.8
>= 1.3.0, < 1.3.4
>= 1.4.0, < 1.4.2
>= 1.5.0, < 1.5.1
1.2.8
1.3.4
1.4.2
1.5.1
GHSA-rg2q-2jh9-447q
Gas mispricing in cosmwasm-vm
Medium
>= 0.0.0-0, < 1.5.7
>= 2.0.0, < 2.0.6
>= 2.1.0, < 2.1.3
1.5.7
2.0.6
2.1.3
GHSA-rg2q-2jh9-447q
Gas mispricing in cosmwasm-vm
Medium
>= 2.1.0, < 2.1.2
2.1.2
GHSA-rg2q-2jh9-447q
Gas mispricing in cosmwasm-vm
Medium
>= 2.0.0, < 2.0.5
2.0.5
GHSA-rg2q-2jh9-447q
Gas mispricing in cosmwasm-vm
Medium
< 1.5.6
1.5.6
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor