comrak (crates.io)
Advisories
7
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 0.17.0 or later clears every advisory below that has a fix.
Upgrade commands
cargo
cargo update -p comrak --precise 0.17.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-5r3x-p7xx-x6q5 Comrak AST node data is not validated (GHSL-2023-049) |
Critical EPSS 1.27% |
< 0.17.0 | 0.17.0 |
| GHSA-xxmq-4vph-956w Comrak vulnerable to production of excessive output when parsing Markdown (GHSL-2023-048) |
Medium | < 0.17.0 | 0.17.0 |
| GHSA-8hqf-xjwp-p67v Comrak vulnerable to quadratic runtime issues when parsing Markdown (GHSL-2023-047) |
High EPSS 1.12% |
< 0.17.0 | 0.17.0 |
| GHSA-6wj2-g87r-pm62 Cross-site Scripting in comrak |
Medium EPSS 0.74% |
>= 0.0.0-0, < 0.10.1 | 0.10.1 |
| GHSA-6wj2-g87r-pm62 Cross-site Scripting in comrak |
Medium EPSS 0.74% |
< 0.10.1 | 0.10.1 |
| GHSA-xmr7-v725-2jjr Cross site scripting in comrak |
Medium EPSS 0.69% |
>= 0.0.0-0, < 0.9.1 | 0.9.1 |
| GHSA-xmr7-v725-2jjr Cross site scripting in comrak |
Medium EPSS 0.69% |
< 0.9.1 | 0.9.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor