webrick (RubyGems)
Advisories
8
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.8.2 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update webrick # Gemfile: gem "webrick", ">= 1.8.2"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-r995-q44h-hr64 Ruby WEBrick read_headers method can lead to HTTP Request/Response Smuggling |
Medium EPSS 0.50% |
< 1.8.2 | 1.8.2 |
| GHSA-6f62-3596-g6w7 HTTP Request Smuggling in ruby webrick |
High | < 1.8.2 | 1.8.2 |
| GHSA-gwfg-cqmg-cf8f WEBRick vulnerable to HTTP Request/Response Smuggling |
High EPSS 3.82% |
>= 1.6.0, < 1.6.1 | 1.6.1 |
| GHSA-gwfg-cqmg-cf8f WEBRick vulnerable to HTTP Request/Response Smuggling |
High EPSS 3.82% |
>= 1.5.0, < 1.5.1 | 1.5.1 |
| GHSA-gwfg-cqmg-cf8f WEBRick vulnerable to HTTP Request/Response Smuggling |
High EPSS 3.82% |
< 1.4.4 | 1.4.4 |
| GHSA-369m-2gv6-mw28 WEBrick RCE Vulnerability |
High EPSS 16.41% |
< 1.4.0 | 1.4.0 |
| GHSA-wfrc-r6c6-7j9r WEBrick Denial of Service Vulnerability |
High EPSS 13.55% |
< 1.3.1 | 1.3.1 |
| GHSA-6mq2-37j5-w6r6 WEBrick Improper Input Validation vulnerability |
Medium EPSS 16.23% |
< 1.4.0 | 1.4.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor