Skip to content

sidekiq (RubyGems)

Advisories
8
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 7.2.4 or later clears every advisory below that has a fix.

Upgrade commands
bundler
bundle update sidekiq # Gemfile: gem "sidekiq", ">= 7.2.4"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-q655-3pj8-9fxq
Sidekiq vulnerable to a Reflected XSS in Queues Web Page
Medium
EPSS 0.59%
>= 7.2.0, < 7.2.4
7.2.4
GHSA-3qc2-v3hp-6cv8
sidekiq Denial of Service vulnerability
Medium
EPSS 0.94%
>= 7.0.0, < 7.1.3
7.1.3
GHSA-3qc2-v3hp-6cv8
sidekiq Denial of Service vulnerability
Medium
EPSS 0.94%
< 6.5.10
6.5.10
GHSA-h3r8-h5qw-4r35
sidekiq vulnerable to cross-site scripting
High
EPSS 2.74%
>= 7.0.4, < 7.0.8
7.0.8
GHSA-jrfj-98qg-qjgv
Denial of service in sidekiq
High
EPSS 5.21%
>= 6.0.0, < 6.4.0
6.4.0
GHSA-jrfj-98qg-qjgv
Denial of service in sidekiq
High
EPSS 5.21%
< 5.2.10
5.2.10
GHSA-grh7-935j-hg6w
Cross-site Scripting in Sidekiq
Medium
EPSS 4.16%
>= 6.0.0, < 6.2.1
6.2.1
GHSA-grh7-935j-hg6w
Cross-site Scripting in Sidekiq
Medium
EPSS 4.16%
< 5.2.0
5.2.0
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor