rubyzip (RubyGems)
Advisories
5
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 3.4.0 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update rubyzip # Gemfile: gem "rubyzip", ">= 3.4.0"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-47m2-wp7j-p9vc rubyzip path traversal vulnerability |
High EPSS 0.56% |
< 3.4.0 | 3.4.0 |
| GHSA-5m2v-hc64-56h6 Rubyzip denial of service |
Medium EPSS 1.58% |
< 1.3.0 | 1.3.0 |
| GHSA-vqcq-mrmw-mcmg Rubyzip gem contains a Directory Traversal vulnerability in zip file component |
Critical EPSS 4.41% |
< 1.2.2 | 1.2.2 |
| GHSA-3q5q-f79q-7hr2 High severity vulnerability that affects rubyzip Withdrawn |
High | < 1.2.1 | 1.2.1 |
| GHSA-gcqq-w6gr-h9j9 Directory traversal vulnerability in RubyZip |
Critical EPSS 3.44% |
< 1.2.1 | 1.2.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor