rails-html-sanitizer (RubyGems)
Advisories
18
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 1.7.1 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update rails-html-sanitizer # Gemfile: gem "rails-html-sanitizer", ">= 1.7.1"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-cj75-f6xr-r4g7 Rails HTML Sanitizers: Possible XSS vulnerability with certain configurations |
Medium EPSS 0.55% |
>= 1.0.3, < 1.7.1 | 1.7.1 |
| GHSA-2x5m-9ch4-qgrr rails-html-sanitizer has XSS vulnerability with certain configurations |
Medium EPSS 0.45% |
>= 1.6.0, < 1.6.1 | 1.6.1 |
| GHSA-cfjx-w229-hgx5 rails-html-sanitizer has XSS vulnerability with certain configurations |
Medium EPSS 0.45% |
>= 1.6.0, < 1.6.1 | 1.6.1 |
| GHSA-638j-pmjw-jq48 rails-html-sanitizer has XSS vulnerability with certain configurations |
Medium EPSS 0.47% |
>= 1.6.0, < 1.6.1 | 1.6.1 |
| GHSA-w8gc-x259-rc7x rails-html-sanitize has XSS vulnerability with certain configurations |
Medium EPSS 0.60% |
>= 1.6.0, < 1.6.1 | 1.6.1 |
| GHSA-rxv5-gxqc-xx8g rails-html-sanitizer has XSS vulnerability with certain configurations |
Medium EPSS 0.47% |
>= 1.6.0, < 1.6.1 | 1.6.1 |
| GHSA-rrfc-7g8p-99q8 Possible XSS vulnerability with certain configurations of rails-html-sanitizer |
Medium EPSS 1.19% |
< 1.4.4 | 1.4.4 |
| GHSA-9h9g-93gc-623h Possible XSS vulnerability with certain configurations of rails-html-sanitizer |
Medium EPSS 1.05% |
< 1.4.4 | 1.4.4 |
| GHSA-mcvf-2q2m-x72m Improper neutralization of data URIs may allow XSS in rails-html-sanitizer |
Medium EPSS 0.92% |
>= 1.0.3, < 1.4.4 | 1.4.4 |
| GHSA-5x79-w82f-gw8w Inefficient Regular Expression Complexity in rails-html-sanitizer |
High EPSS 1.58% |
< 1.4.4 | 1.4.4 |
| GHSA-pg8v-g4xq-hww9 Rails::Html::Sanitizer vulnerable to Cross-site Scripting |
Medium EPSS 30.23% |
< 1.4.3 | 1.4.3 |
| GHSA-77pc-q5q7-qg9h Moderate severity vulnerability that affects rails-html-sanitizer Withdrawn |
Medium | < 1.0.3 | 1.0.3 |
| GHSA-mrhj-2g4v-39qx Moderate severity vulnerability that affects rails-html-sanitizer Withdrawn |
Medium | >= 1.0.2, < 1.0.3 | 1.0.3 |
| GHSA-qc8j-m8j3-rjq6 Moderate severity vulnerability that affects rails-html-sanitizer Withdrawn |
Medium | < 1.0.3 | 1.0.3 |
| GHSA-px3r-jm9g-c8w8 rails-html-sanitizer Cross-site Scripting vulnerability |
Medium EPSS 1.25% |
< 1.0.4 | 1.0.4 |
| GHSA-r9c2-cr39-c8g6 rails-html-sanitizer Cross-site Scripting vulnerability |
Medium EPSS 2.58% |
< 1.0.3 | 1.0.3 |
| GHSA-ghqm-pgxj-37gq rails-html-sanitizer Cross-site Scripting vulnerability |
Medium EPSS 2.19% |
< 1.0.3 | 1.0.3 |
| GHSA-59c7-4xj2-hgvw rails-html-sanitizer Cross-site Scripting vulnerability |
Medium EPSS 2.48% |
< 1.0.3 | 1.0.3 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor