passenger (RubyGems)
Advisories
16
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 6.0.26 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update passenger # Gemfile: gem "passenger", ">= 6.0.26"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-2cj2-qqxj-5m3r Phusion Passenger denial of service |
High EPSS 0.62% |
>= 6.0.21, < 6.0.26 | 6.0.26 |
| GHSA-jjcj-fgfm-9g9r Phusion Passenger Race Condition Allows Privilege Escalation |
High EPSS 0.27% |
>= 3.0.0, < 5.3.2 | 5.3.2 |
| GHSA-7cv3-gvmc-8mq5 Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability |
Critical EPSS 1.92% |
>= 5.3.0, < 5.3.2 | 5.3.2 |
| GHSA-4284-jfhc-f854 Phusion Passenger incorrect permission assignment |
Medium EPSS 1.18% |
< 5.3.2 | 5.3.2 |
| GHSA-jjhj-8gx7-x836 Incorrect Access Control in Phusion Passenger |
High EPSS 0.89% |
>= 5.3.0, < 5.3.2 | 5.3.2 |
| GHSA-whfx-877c-5p28 Insecure Permissions in Phusion Passenger |
High EPSS 1.07% |
>= 5.3.0, < 5.3.2 | 5.3.2 |
| GHSA-cv3f-px9r-54hm Phusion Passenger information disclosure |
Medium EPSS 0.36% |
< 5.1.11 | 5.1.11 |
| GHSA-8mw8-j583-vqfg RubyGems passenger gem allows remote attackers to delete files |
High EPSS 2.31% |
< 4.0.0.rc4 | 4.0.0.rc4 |
| GHSA-qw8w-2xcp-xg59 Insecure use of temporary files in Phusion passenger |
Low EPSS 0.37% |
>= 4.0.37, < 4.0.38 | 4.0.38 |
| GHSA-c7j7-p5jq-26ff Insecure use of temporary files in passenger |
Low EPSS 0.37% |
< 4.0.38 | 4.0.38 |
| GHSA-fxwv-953p-7qpf Phusion Passenger allows remote attackers to spoof headers |
Low EPSS 2.36% |
>= 5.0.0, < 5.0.22 | 5.0.22 |
| GHSA-fxwv-953p-7qpf Phusion Passenger allows remote attackers to spoof headers |
Low EPSS 2.36% |
< 4.0.60 | 4.0.60 |
| GHSA-cqxw-3p7v-p9gr Phusion Passenger uses a known /tmp filename |
High EPSS 0.46% |
< 5.1.0 | 5.1.0 |
| GHSA-w6rc-q387-vpgq insecure temporary directory usage in passenger |
Medium EPSS 0.33% |
< 4.0.6 | 4.0.6 |
| GHSA-9qj7-jvg4-qr2x Phusion Passenger Denial of Service |
Medium EPSS 0.40% |
>= 4.0.1, < 4.0.5 | 4.0.5 |
| GHSA-9qj7-jvg4-qr2x Phusion Passenger Denial of Service |
Medium EPSS 0.40% |
< 3.0.21 | 3.0.21 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor