Skip to content

lodash-rails (RubyGems)

Advisories
14
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 4.17.21 or later clears every advisory below that has a fix.

Upgrade commands
bundler
bundle update lodash-rails # Gemfile: gem "lodash-rails", ">= 4.17.21"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-29mw-wpgm-hmr9
Regular Expression Denial of Service (ReDoS) in lodash
Medium
EPSS 7.34%
>= 4.0.0, < 4.17.21
4.17.21
GHSA-29mw-wpgm-hmr9
Regular Expression Denial of Service (ReDoS) in lodash
Medium
EPSS 7.34%
>= 4.0.0, < 4.17.21
4.17.21
GHSA-35jh-r3h4-6jhm
Command Injection in lodash
High
EPSS 21.33%
< 4.17.21
4.17.21
GHSA-35jh-r3h4-6jhm
Command Injection in lodash
High
EPSS 21.33%
< 4.17.21
4.17.21
GHSA-p6mc-m468-83gw
Prototype Pollution in lodash
High
EPSS 5.21%
>= 3.7.0, < 4.17.19
4.17.19
GHSA-p6mc-m468-83gw
Prototype Pollution in lodash
High
EPSS 5.21%
>= 3.7.0, < 4.17.19
4.17.19
GHSA-x5rq-j2xg-h7qm
Regular Expression Denial of Service (ReDoS) in lodash
Medium
EPSS 3.04%
>= 4.7.0, < 4.17.11
4.17.11
GHSA-x5rq-j2xg-h7qm
Regular Expression Denial of Service (ReDoS) in lodash
Medium
EPSS 3.04%
>= 4.7.0, < 4.17.11
4.17.11
GHSA-jf85-cpcp-j695
Prototype Pollution in lodash
Critical
EPSS 5.01%
< 4.17.12
4.17.12
GHSA-jf85-cpcp-j695
Prototype Pollution in lodash
Critical
EPSS 5.01%
< 4.17.12
4.17.12
GHSA-4xc9-xhrj-v574
Prototype Pollution in lodash
High
EPSS 1.49%
< 4.17.11
4.17.11
GHSA-4xc9-xhrj-v574
Prototype Pollution in lodash
High
EPSS 1.49%
< 4.17.11
4.17.11
GHSA-fvqr-27wr-82fm
Prototype Pollution in lodash
Medium
EPSS 2.35%
< 4.17.5
4.17.5
GHSA-fvqr-27wr-82fm
Prototype Pollution in lodash
Medium
EPSS 2.35%
< 4.17.5
4.17.5
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor