Skip to content

grpc (RubyGems)

Advisories
13
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 1.56.2 or later clears every advisory below that has a fix.

Upgrade commands
bundler
bundle update grpc # Gemfile: gem "grpc", ">= 1.56.2"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-p25m-jpj4-qcrr
Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)
High
EPSS 0.77%
>= 1.54.0, < 1.54.3
1.54.3
GHSA-p25m-jpj4-qcrr
Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)
High
EPSS 0.77%
>= 1.55.0, < 1.55.3
1.55.3
GHSA-p25m-jpj4-qcrr
Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)
High
EPSS 0.77%
>= 1.56.0, < 1.56.2
1.56.2
GHSA-p25m-jpj4-qcrr
Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)
High
EPSS 0.77%
>= 1.53.0, < 1.53.2
1.53.2
GHSA-496j-2rq6-j6cc
Excessive Iteration in gRPC
High
EPSS 0.48%
< 1.53.2
1.53.2
GHSA-496j-2rq6-j6cc
Excessive Iteration in gRPC
High
EPSS 0.48%
>= 1.54.0, < 1.54.3
1.54.3
GHSA-496j-2rq6-j6cc
Excessive Iteration in gRPC
High
EPSS 0.48%
>= 1.55.0, < 1.55.2
1.55.2
GHSA-496j-2rq6-j6cc
Excessive Iteration in gRPC
High
EPSS 0.48%
>= 1.56.0, < 1.56.2
1.56.2
GHSA-9hxf-ppjv-w6rq
gRPC connection termination issue
Medium
EPSS 0.53%
>= 1.53.0, < 1.53.1
1.53.1
GHSA-9hxf-ppjv-w6rq
gRPC connection termination issue
Medium
EPSS 0.53%
>= 1.54.0, < 1.54.2
1.54.2
GHSA-6628-q6j9-w8vg
gRPC Reachable Assertion issue
High
EPSS 0.41%
>= 1.51.0, < 1.53.0
1.53.0
GHSA-cfgp-2977-2fmm
Connection confusion in gRPC
High
EPSS 0.50%
>= 1.53.0, < 1.53.1
1.53.1
GHSA-cfgp-2977-2fmm
Connection confusion in gRPC
High
EPSS 0.50%
>= 1.54.0, < 1.54.2
1.54.2
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor