Skip to content

ember-source (RubyGems)

Advisories
27
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 2.2.1 or later clears every advisory below that has a fix.

Upgrade commands
bundler
bundle update ember-source # Gemfile: gem "ember-source", ">= 2.2.1"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-5m48-c37x-f792
Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
Medium
EPSS 0.94%
>= 1.0.0.rc5.0, < 1.0.0.rc5.1
1.0.0.rc5.1
GHSA-5m48-c37x-f792
Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
Medium
EPSS 0.94%
>= 1.0.0.rc4.0, < 1.0.0.rc4.1
1.0.0.rc4.1
GHSA-5m48-c37x-f792
Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
Medium
EPSS 0.94%
< 1.0.0.rc1.1
1.0.0.rc1.1
GHSA-5m48-c37x-f792
Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
Medium
EPSS 0.94%
>= 1.0.0.rc2.0, < 1.0.0.rc2.1
1.0.0.rc2.1
GHSA-5m48-c37x-f792
Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
Medium
EPSS 0.94%
>= 1.0.0.rc3.0, < 1.0.0.rc3.1
1.0.0.rc3.1
GHSA-5m48-c37x-f792
Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
Medium
EPSS 0.94%
>= 1.0.0.rc6.0, < 1.0.0.rc6.1
1.0.0.rc6.1
GHSA-8xm3-gm7c-5fjx
Ember.js Cross-site Scripting vulnerability
Medium
EPSS 0.67%
>= 1.4.0-beta.1, < 1.4.0-beta.2
1.4.0-beta.2
GHSA-8xm3-gm7c-5fjx
Ember.js Cross-site Scripting vulnerability
Medium
EPSS 0.67%
>= 1.0.0.pre4.0, < 1.0.1
1.0.1
GHSA-8xm3-gm7c-5fjx
Ember.js Cross-site Scripting vulnerability
Medium
EPSS 0.67%
>= 1.1.0, < 1.1.3
1.1.3
GHSA-8xm3-gm7c-5fjx
Ember.js Cross-site Scripting vulnerability
Medium
EPSS 0.67%
>= 1.2.0.beta.1, < 1.2.1
1.2.1
GHSA-8xm3-gm7c-5fjx
Ember.js Cross-site Scripting vulnerability
Medium
EPSS 0.67%
>= 1.3.0.beta.1, < 1.3.1
1.3.1
GHSA-rcx6-7jp6-pqf2
ember-source Cross-site Scripting vulnerability
Medium
EPSS 1.20%
>= 1.4.0-beta.1, < 1.4.0-beta.2
1.4.0-beta.2
GHSA-rcx6-7jp6-pqf2
ember-source Cross-site Scripting vulnerability
Medium
EPSS 1.20%
>= 1.2.0.beta.1, < 1.2.1
1.2.1
GHSA-rcx6-7jp6-pqf2
ember-source Cross-site Scripting vulnerability
Medium
EPSS 1.20%
>= 1.1.0, < 1.1.3
1.1.3
GHSA-rcx6-7jp6-pqf2
ember-source Cross-site Scripting vulnerability
Medium
EPSS 1.20%
>= 1.0.0.pre4.0, < 1.0.1
1.0.1
GHSA-rcx6-7jp6-pqf2
ember-source Cross-site Scripting vulnerability
Medium
EPSS 1.20%
>= 1.3.0.beta.1, < 1.3.1
1.3.1
GHSA-mp78-r56v-45qc
ember-source vulnerable to Cross-site Scripting
Medium
EPSS 1.12%
>= 1.11.0, < 1.11.2
1.11.2
GHSA-mp78-r56v-45qc
ember-source vulnerable to Cross-site Scripting
Medium
EPSS 1.12%
>= 1.10.0, < 1.10.1
1.10.1
GHSA-4q53-fqhc-cr46
ember-source Cross-site Scripting vulnerability
Low
EPSS 1.50%
>= 1.4.0.beta.1, < 1.4.0.beta.6
1.4.0.beta.6
GHSA-4q53-fqhc-cr46
ember-source Cross-site Scripting vulnerability
Low
EPSS 1.50%
>= 1.3.0, < 1.3.2
1.3.2
GHSA-4q53-fqhc-cr46
ember-source Cross-site Scripting vulnerability
Low
EPSS 1.50%
>= 1.2.0, < 1.2.2
1.2.2
GHSA-m3q7-rj8g-m457
ember-source Cross-site Scripting vulnerability
Medium
EPSS 0.82%
>= 2.2.0, < 2.2.1
2.2.1
GHSA-m3q7-rj8g-m457
ember-source Cross-site Scripting vulnerability
Medium
EPSS 0.82%
>= 2.1.0, < 2.1.2
2.1.2
GHSA-m3q7-rj8g-m457
ember-source Cross-site Scripting vulnerability
Medium
EPSS 0.82%
>= 2.0.0, < 2.0.3
2.0.3
GHSA-m3q7-rj8g-m457
ember-source Cross-site Scripting vulnerability
Medium
EPSS 0.82%
>= 1.13.0, < 1.13.12
1.13.12
GHSA-m3q7-rj8g-m457
ember-source Cross-site Scripting vulnerability
Medium
EPSS 0.82%
>= 1.12.0, < 1.12.2
1.12.2
GHSA-m3q7-rj8g-m457
ember-source Cross-site Scripting vulnerability
Medium
EPSS 0.82%
>= 1.8.0, < 1.11.4
1.11.4
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor