doorkeeper (RubyGems)
Advisories
10
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 5.6.6 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update doorkeeper # Gemfile: gem "doorkeeper", ">= 5.6.6"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-7w2c-w47h-789w Doorkeeper Improper Authentication vulnerability |
Medium EPSS 0.72% |
< 5.6.6 | 5.6.6 |
| GHSA-j7vx-8mqj-cqp9 Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper |
High EPSS 1.78% |
>= 5.2.0, < 5.2.5 | 5.2.5 |
| GHSA-j7vx-8mqj-cqp9 Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper |
High EPSS 1.78% |
>= 5.3.0, < 5.3.2 | 5.3.2 |
| GHSA-j7vx-8mqj-cqp9 Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper |
High EPSS 1.78% |
>= 5.0.0, < 5.0.3 | 5.0.3 |
| GHSA-j7vx-8mqj-cqp9 Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper |
High EPSS 1.78% |
>= 5.1.0, < 5.1.1 | 5.1.1 |
| GHSA-685w-vc84-wxcx Doorkeeper vulnerable to Cross-site Request Forgery |
Medium EPSS 0.65% |
< 1.4.1 | 1.4.1 |
| GHSA-5p9f-55j8-922m Moderate severity vulnerability that affects doorkeeper Withdrawn |
Medium | >= 1.2.0, < 4.2.0 | 4.2.0 |
| GHSA-694m-jhr9-pf77 Doorkeeper subject to Incorrect Permission Assignment |
High EPSS 1.55% |
>= 4.2.0, < 4.4.0 | 4.4.0 |
| GHSA-hwhh-2fwm-cfgw Doorkeeper is vulnerable to stored XSS and code execution |
Medium EPSS 1.43% |
>= 2.1.0, < 4.2.6 | 4.2.6 |
| GHSA-3m6r-39p3-jq25 Doorkeeper is vulnerable to replay attacks |
Critical EPSS 4.81% |
< 4.2.0 | 4.2.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor