commonmarker (RubyGems)
Advisories
6
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 0.23.10 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update commonmarker # Gemfile: gem "commonmarker", ">= 0.23.10"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-c2v4-chx5-vff6 Duplicate Advisory: Integer overflow in cmark-gfm table parsing extension leads to heap memory corruption Withdrawn |
High | all versions | No fix yet |
| GHSA-7vh7-fw88-wj87 Several quadratic complexity bugs may lead to denial of service in Commonmarker |
Medium | < 0.23.10 | 0.23.10 |
| GHSA-48wp-p9qv-4j64 Commonmarker vulnerable to to several quadratic complexity bugs that may lead to denial of service |
Medium | < 0.23.9 | 0.23.9 |
| GHSA-636f-xm5j-pj9m Several quadratic complexity bugs may lead to denial of service in Commonmarker |
Medium | < 0.23.7 | 0.23.7 |
| GHSA-4qw4-jpp4-8gvp Unbounded resource exhaustion in cmark-gfm autolink extension may lead to denial of service |
Medium | < 0.23.6 | 0.23.6 |
| GHSA-fmx4-26r3-wxpf Integer overflow in cmark-gfm table parsing extension leads to heap memory corruption |
Critical EPSS 1.45% |
< 0.23.4 | 0.23.4 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor