cgi (RubyGems)
Advisories
15
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 0.4.2 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update cgi # Gemfile: gem "cgi", ">= 0.4.2"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-mhwm-jh88-3gjf CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement |
High EPSS 0.76% |
< 0.3.5.1 | 0.3.5.1 |
| GHSA-mhwm-jh88-3gjf CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement |
High EPSS 0.76% |
>= 0.4.0, < 0.4.2 | 0.4.2 |
| GHSA-mhwm-jh88-3gjf CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement |
High EPSS 0.76% |
>= 0.3.6, < 0.3.7 | 0.3.7 |
| GHSA-gh9q-2xrm-x6qv CGI has Denial of Service (DoS) potential in Cookie.parse |
High EPSS 0.85% |
< 0.3.5.1 | 0.3.5.1 |
| GHSA-gh9q-2xrm-x6qv CGI has Denial of Service (DoS) potential in Cookie.parse |
High EPSS 0.85% |
>= 0.4.0, < 0.4.2 | 0.4.2 |
| GHSA-gh9q-2xrm-x6qv CGI has Denial of Service (DoS) potential in Cookie.parse |
High EPSS 0.85% |
>= 0.3.6, < 0.3.7 | 0.3.7 |
| GHSA-vc47-6rqg-c7f5 HTTP response splitting in CGI |
High EPSS 2.45% |
>= 0.2.0, < 0.2.2 | 0.2.2 |
| GHSA-vc47-6rqg-c7f5 HTTP response splitting in CGI |
High EPSS 2.45% |
< 0.1.0.2 | 0.1.0.2 |
| GHSA-vc47-6rqg-c7f5 HTTP response splitting in CGI |
High EPSS 2.45% |
>= 0.3.0, < 0.3.5 | 0.3.5 |
| GHSA-4vf4-qmvg-mh7h Cookie Prefix Spoofing in CGI::Cookie.parse |
High EPSS 3.15% |
< 0.1.0.1 | 0.1.0.1 |
| GHSA-4vf4-qmvg-mh7h Cookie Prefix Spoofing in CGI::Cookie.parse |
High EPSS 3.15% |
>= 0.2.0, < 0.2.1 | 0.2.1 |
| GHSA-4vf4-qmvg-mh7h Cookie Prefix Spoofing in CGI::Cookie.parse |
High EPSS 3.15% |
>= 0.3.0, < 0.3.1 | 0.3.1 |
| GHSA-5cqm-crxm-6qpv Buffer overrun in CGI.escape_html |
Critical EPSS 4.90% |
< 0.1.0.1 | 0.1.0.1 |
| GHSA-5cqm-crxm-6qpv Buffer overrun in CGI.escape_html |
Critical EPSS 4.90% |
>= 0.2.0, < 0.2.1 | 0.2.1 |
| GHSA-5cqm-crxm-6qpv Buffer overrun in CGI.escape_html |
Critical EPSS 4.90% |
>= 0.3.0, < 0.3.1 | 0.3.1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor