camaleon_cms (RubyGems)
Advisories
16
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.9.1 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update camaleon_cms # Gemfile: gem "camaleon_cms", ">= 2.9.1"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-jw5g-f64p-6x78 Camaleon CMS vulnerable to Path Traversal through AWS S3 uploader implementation |
Medium EPSS 0.78% |
>= 2.4.5.0, <= 2.9.1 | No fix yet |
| GHSA-rp28-mvq3-wf8j Camaleon CMS Vulnerable to Privilege Escalation through a Mass Assignment |
Critical EPSS 0.63% |
< 2.9.1 | 2.9.1 |
| GHSA-hhxg-rvc9-8726 camaleon_cms affected by cross site scripting |
Medium EPSS 1.11% |
<= 2.7.5 | No fix yet |
| GHSA-75j2-9gmc-m855 Camaleon CMS vulnerable to stored XSS through user file upload (GHSL-2024-184) |
Medium | >= 2.8.0, < 2.8.2 | 2.8.2 |
| GHSA-8fx8-3rg2-79xw Camaleon CMS vulnerable to stored XSS through user file upload (GHSL-2024-184) |
Medium | < 2.8.1 | 2.8.1 |
| GHSA-3hp8-6j24-m5gm Duplicate Advisory: Camaleon CMS vulnerable to remote code execution through code injection (GHSL-2024-185) Withdrawn |
High | < 2.8.1 | 2.8.1 |
| GHSA-7x4w-cj9r-h4v9 Camaleon CMS vulnerable to remote code execution through code injection (GHSL-2024-185) |
High | < 2.8.1 | 2.8.1 |
| GHSA-r9cr-qmfw-pmrc Camaleon CMS vulnerable to stored XSS through user file upload (GHSL-2024-184) |
Medium | < 2.8.1 | 2.8.1 |
| GHSA-cp65-5m9r-vc2c Camaleon CMS vulnerable to arbitrary path traversal (GHSL-2024-183) |
High EPSS 14.56% |
< 2.8.1 | 2.8.1 |
| GHSA-wmjg-vqhv-q5p5 Camaleon CMS affected by arbitrary file write to RCE (GHSL-2024-182) |
Critical EPSS 37.11% |
>= 2.8.0, < 2.8.1 | 2.8.1 |
| GHSA-x487-866m-p8hr Server-Side Template Injection in Camaleon CMS |
Critical EPSS 45.86% |
< 2.7.4 | 2.7.4 |
| GHSA-x78v-4fvj-rg9j Camaleon CMS Stored Cross-site Scripting vulnerability |
Medium EPSS 0.81% |
>= 0.0.1, < 2.6.0.1 | 2.6.0.1 |
| GHSA-438x-2p9v-g8h9 Camaleon CMS Insufficient Session Expiration vulnerability |
High EPSS 1.31% |
>= 0.1.7, < 2.6.0.1 | 2.6.0.1 |
| GHSA-r2w2-h6r8-3r53 Camaleon CMS vulnerable to Uncaught Exception |
Medium EPSS 1.01% |
>= 2.0.1, < 2.6.0.1 | 2.6.0.1 |
| GHSA-vx6p-q4gj-x6xx Camaleon CMS vulnerable to Server-Side Request Forgery |
Medium EPSS 0.99% |
>= 2.1.2.0, < 2.6.0.1 | 2.6.0.1 |
| GHSA-7f84-9cqf-g4j9 Camaleon CMS vulnerable to Stored Cross-site Scripting |
Medium EPSS 1.05% |
No fix yet |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor