activesupport (RubyGems)
Advisories
44
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 8.1.2.1 or later clears every advisory below that has a fix.
Upgrade commands
bundler
bundle update activesupport # Gemfile: gem "activesupport", ">= 8.1.2.1"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-2j26-frm8-cmj9 Rails Active Support has a possible DoS vulnerability in its number helpers |
High EPSS 0.86% |
< 7.2.3.1 | 7.2.3.1 |
| GHSA-2j26-frm8-cmj9 Rails Active Support has a possible DoS vulnerability in its number helpers |
High EPSS 0.86% |
>= 8.0.0.beta1, < 8.0.4.1 | 8.0.4.1 |
| GHSA-2j26-frm8-cmj9 Rails Active Support has a possible DoS vulnerability in its number helpers |
High EPSS 0.86% |
>= 8.1.0.beta1, < 8.1.2.1 | 8.1.2.1 |
| GHSA-89vf-4333-qx8v Rails Active Support has a possible XSS vulnerability in SafeBuffer#% |
Medium EPSS 0.34% |
< 7.2.3.1 | 7.2.3.1 |
| GHSA-89vf-4333-qx8v Rails Active Support has a possible XSS vulnerability in SafeBuffer#% |
Medium EPSS 0.34% |
>= 8.1.0.beta1, < 8.1.2.1 | 8.1.2.1 |
| GHSA-89vf-4333-qx8v Rails Active Support has a possible XSS vulnerability in SafeBuffer#% |
Medium EPSS 0.34% |
>= 8.0.0.beta1, < 8.0.4.1 | 8.0.4.1 |
| GHSA-cg4j-q9v8-6v38 Rails Active Support has a possible ReDoS vulnerability in number_to_delimited |
Medium EPSS 0.66% |
>= 8.0.0.beta1, < 8.0.4.1 | 8.0.4.1 |
| GHSA-cg4j-q9v8-6v38 Rails Active Support has a possible ReDoS vulnerability in number_to_delimited |
Medium EPSS 0.66% |
< 7.2.3.1 | 7.2.3.1 |
| GHSA-cg4j-q9v8-6v38 Rails Active Support has a possible ReDoS vulnerability in number_to_delimited |
Medium EPSS 0.66% |
>= 8.1.0.beta1, < 8.1.2.1 | 8.1.2.1 |
| GHSA-cr5q-6q9f-rq6q Active Support Possibly Discloses Locally Encrypted Files |
Medium EPSS 0.27% |
>= 7.0.0, < 7.0.7.1 | 7.0.7.1 |
| GHSA-cr5q-6q9f-rq6q Active Support Possibly Discloses Locally Encrypted Files |
Medium EPSS 0.27% |
>= 5.2.0, < 6.1.7.5 | 6.1.7.5 |
| GHSA-pj73-v5mw-pm9j Possible XSS Security Vulnerability in SafeBuffer#bytesplice |
Medium EPSS 0.95% |
< 6.1.7.3 | 6.1.7.3 |
| GHSA-pj73-v5mw-pm9j Possible XSS Security Vulnerability in SafeBuffer#bytesplice |
Medium EPSS 0.95% |
>= 7.0.0, < 7.0.4.3 | 7.0.4.3 |
| GHSA-j6gc-792m-qgm2 ReDoS based DoS vulnerability in Active Support's underscore |
Low EPSS 1.71% |
< 6.1.7.1 | 6.1.7.1 |
| GHSA-j6gc-792m-qgm2 ReDoS based DoS vulnerability in Active Support's underscore |
Low EPSS 1.71% |
>= 7.0.0, < 7.0.4.1 | 7.0.4.1 |
| GHSA-2p68-f74v-9wc6 ActiveSupport potentially unintended unmarshalling of user-provided objects in MemCacheStore and RedisCacheStore |
Critical EPSS 45.73% |
>= 6.0.0, < 6.0.3.1 | 6.0.3.1 |
| GHSA-2p68-f74v-9wc6 ActiveSupport potentially unintended unmarshalling of user-provided objects in MemCacheStore and RedisCacheStore |
Critical EPSS 45.73% |
>= 5.0.0, < 5.2.4.3 | 5.2.4.3 |
| GHSA-35c4-f3rq-f9g3 Moderate severity vulnerability that affects activesupport Withdrawn |
Medium | >= 4.0.0, < 4.1.11 | 4.1.11 |
| GHSA-35c4-f3rq-f9g3 Moderate severity vulnerability that affects activesupport Withdrawn |
Medium | >= 3.2.0, < 3.2.22 | 3.2.22 |
| GHSA-35c4-f3rq-f9g3 Moderate severity vulnerability that affects activesupport Withdrawn |
Medium | >= 4.2.0, < 4.2.2 | 4.2.2 |
| GHSA-v9v4-7jp6-8c73 rails Cross-site Scripting vulnerability |
Medium EPSS 1.96% |
>= 3.0.0, < 3.0.8 | 3.0.8 |
| GHSA-8qrh-h9m2-5fvf Cross site scripting that affects rails |
Medium EPSS 3.02% |
>= 2.3.0, < 2.3.4 | 2.3.4 |
| GHSA-fg9w-g6m4-557j actionpack and activesupport vulnerable to information leaks |
Medium EPSS 2.23% |
>= 2.1.0, < 2.2.3 | 2.2.3 |
| GHSA-fg9w-g6m4-557j actionpack and activesupport vulnerable to information leaks |
Medium EPSS 2.23% |
>= 2.3.0, < 2.3.4 | 2.3.4 |
| GHSA-v9v4-7jp6-8c73 rails Cross-site Scripting vulnerability |
Medium EPSS 1.96% |
>= 2.0.0, < 2.3.12 | 2.3.12 |
| GHSA-8qrh-h9m2-5fvf Cross site scripting that affects rails |
Medium EPSS 3.02% |
>= 2.0.0, < 2.2.3 | 2.2.3 |
| GHSA-9fh3-vh3h-q4g3 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.49% |
>= 2.0.0, < 2.3.13 | 2.3.13 |
| GHSA-9fh3-vh3h-q4g3 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.49% |
>= 3.0.0, < 3.0.10 | 3.0.10 |
| GHSA-qv8p-v9qw-wc7g activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.65% |
>= 3.0.0, < 3.0.12 | 3.0.12 |
| GHSA-qv8p-v9qw-wc7g activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.65% |
>= 3.1.0, < 3.1.4 | 3.1.4 |
| GHSA-qv8p-v9qw-wc7g activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.65% |
>= 3.2.0, < 3.2.2 | 3.2.2 |
| GHSA-h835-75hw-pj89 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.57% |
>= 3.2.0, < 3.2.8 | 3.2.8 |
| GHSA-h835-75hw-pj89 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.57% |
>= 3.1.0, < 3.1.8 | 3.1.8 |
| GHSA-h835-75hw-pj89 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.57% |
>= 3.0.0.beta, < 3.0.17 | 3.0.17 |
| GHSA-9c2j-593q-3g82 activesupport Improper Input Validation vulnerability |
Medium EPSS 2.05% |
>= 3.2.0, < 3.2.13 | 3.2.13 |
| GHSA-9c2j-593q-3g82 activesupport Improper Input Validation vulnerability |
Medium EPSS 2.05% |
>= 3.0.0, < 3.1.12 | 3.1.12 |
| GHSA-xgr2-v94m-rc9g activesupport in Rails vulnerable to incorrect data conversion |
High EPSS 95.57% |
>= 2.3.2, < 2.3.16 | 2.3.16 |
| GHSA-xgr2-v94m-rc9g activesupport in Rails vulnerable to incorrect data conversion |
High EPSS 95.57% |
>= 3.0.0, < 3.0.20 | 3.0.20 |
| GHSA-h835-75hw-pj89 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.57% |
< 2.3.16 | 2.3.16 |
| GHSA-j96r-xvjq-r9pg activesupport vulnerable to Denial of Service via large XML document depth |
Medium EPSS 4.26% |
>= 4.0.0.beta1, < 4.1.11 | 4.1.11 |
| GHSA-vxvp-4xwc-jpp6 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.78% |
>= 4.1.0, < 4.1.11 | 4.1.11 |
| GHSA-j96r-xvjq-r9pg activesupport vulnerable to Denial of Service via large XML document depth |
Medium EPSS 4.26% |
< 3.2.22 | 3.2.22 |
| GHSA-j96r-xvjq-r9pg activesupport vulnerable to Denial of Service via large XML document depth |
Medium EPSS 4.26% |
>= 4.2.0.beta1, < 4.2.2 | 4.2.2 |
| GHSA-vxvp-4xwc-jpp6 activesupport Cross-site Scripting vulnerability |
Medium EPSS 2.78% |
>= 4.2.0, < 4.2.2 | 4.2.2 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor