Skip to content

websockets (PyPI)

Library for building WebSocket servers and clients in Python

Advisories
4
Latest version
17.3.0
Released Oct 19, 2026
License
BSD-3-Clause
OpenSSF Scorecard
5.5 / 10

How to fix

Upgrading to 9.1 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "websockets>=17.3.0"
poetry
poetry add "websockets>=17.3.0"
uv
uv add "websockets>=17.3.0"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-8ch4-58qp-g3mp
Observable Timing Discrepancy in aaugustin websockets library
Medium
EPSS 2.27%
< 9.1
9.1
GHSA-8ch4-58qp-g3mp
Observable Timing Discrepancy in aaugustin websockets library
Medium
EPSS 2.27%
< 9.1
9.1
GHSA-6g87-ff9q-v847
websockets is vulnerable to denial of service by memory exhaustion
High
EPSS 1.83%
>= 4.0, < 5.0
5.0
GHSA-6g87-ff9q-v847
websockets is vulnerable to denial of service by memory exhaustion
High
EPSS 1.83%
< 5.0
5.0

Source: https://github.com/python-websockets/websockets

Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor