Skip to content

pyspark (PyPI)

Advisories
5
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 3.2.2 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "pyspark>=3.2.2"
poetry
poetry add "pyspark>=3.2.2"
uv
uv add "pyspark>=3.2.2"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-4x9r-j582-cgr8
Apache Spark UI can allow impersonation if ACLs enabled
Known exploited
High
EPSS 93.24%
< 3.1.3
3.1.3
GHSA-4x9r-j582-cgr8
Apache Spark UI can allow impersonation if ACLs enabled
Known exploited
High
EPSS 93.24%
>= 3.2.0, < 3.2.2
3.2.2
GHSA-4x9r-j582-cgr8
Apache Spark UI can allow impersonation if ACLs enabled
Known exploited
High
EPSS 93.24%
< 3.1.3
3.1.3
GHSA-4x9r-j582-cgr8
Apache Spark UI can allow impersonation if ACLs enabled
Known exploited
High
EPSS 93.24%
>= 3.2.0, < 3.2.2
3.2.2
GHSA-4x9r-j582-cgr8
Apache Spark UI can allow impersonation if ACLs enabled
Known exploited
High
EPSS 93.24%
< 3.1.3
>= 3.2.0, < 3.2.2
3.1.3
3.2.2
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor