protobuf (PyPI)
Advisories
24
Latest version
7.36.2
Released Sep 17, 2026
License
BSD-3-Clause
OpenSSF Scorecard
—
How to fix
Upgrading to 6.33.5 or later clears every advisory below that has a fix.
Upgrade commands
pip
pip install --upgrade "protobuf>=7.36.2"poetry
poetry add "protobuf>=7.36.2"uv
uv add "protobuf>=7.36.2"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-7gcm-g887-7qv7 protobuf affected by a JSON recursion depth bypass |
High EPSS 0.71% |
>= 6.30.0rc1, < 6.33.5 | 6.33.5 |
| GHSA-7gcm-g887-7qv7 protobuf affected by a JSON recursion depth bypass |
High EPSS 0.71% |
< 5.29.6>= 6.30.0rc1, < 6.33.5 | 5.29.66.33.5 |
| GHSA-7gcm-g887-7qv7 protobuf affected by a JSON recursion depth bypass |
High EPSS 0.71% |
< 5.29.6 | 5.29.6 |
| GHSA-7gcm-g887-7qv7 protobuf affected by a JSON recursion depth bypass |
High EPSS 0.71% |
>= 6.30.0rc1, <= 6.33.4 | No fix yet |
| GHSA-7gcm-g887-7qv7 protobuf affected by a JSON recursion depth bypass |
High EPSS 0.71% |
< 5.29.6 | 5.29.6 |
| GHSA-8qvm-5x2c-j2w7 protobuf-python has a potential Denial of Service issue |
High EPSS 0.26% |
< 4.25.8 | 4.25.8 |
| GHSA-8qvm-5x2c-j2w7 protobuf-python has a potential Denial of Service issue |
High EPSS 0.26% |
>= 5.26.0rc1, < 5.29.5 | 5.29.5 |
| GHSA-8qvm-5x2c-j2w7 protobuf-python has a potential Denial of Service issue |
High EPSS 0.26% |
>= 6.30.0rc1, < 6.31.1 | 6.31.1 |
| GHSA-8qvm-5x2c-j2w7 protobuf-python has a potential Denial of Service issue |
High EPSS 0.26% |
< 4.25.8 | 4.25.8 |
| GHSA-8qvm-5x2c-j2w7 protobuf-python has a potential Denial of Service issue |
High EPSS 0.26% |
>= 5.26.0rc1, < 5.29.5 | 5.29.5 |
| GHSA-8qvm-5x2c-j2w7 protobuf-python has a potential Denial of Service issue |
High EPSS 0.26% |
>= 6.30.0rc1, < 6.31.1 | 6.31.1 |
| GHSA-8qvm-5x2c-j2w7 protobuf-python has a potential Denial of Service issue |
High EPSS 0.26% |
< 4.25.8>= 5.26.0rc1, < 5.29.5>= 6.30.0rc1, < 6.31.1 | 4.25.85.29.56.31.1 |
| GHSA-8gq9-2x98-w8hf protobuf-cpp and protobuf-python have potential Denial of Service issue |
High EPSS 1.51% |
< 3.18.3>= 3.19.0, < 3.19.5>= 3.20.0, < 3.20.2>= 4.0.0, < 4.21.6 | 3.18.33.19.53.20.24.21.6 |
| GHSA-8gq9-2x98-w8hf protobuf-cpp and protobuf-python have potential Denial of Service issue |
High EPSS 1.51% |
>= 3.19.0, < 3.19.5 | 3.19.5 |
| GHSA-8gq9-2x98-w8hf protobuf-cpp and protobuf-python have potential Denial of Service issue |
High EPSS 1.51% |
< 3.18.3 | 3.18.3 |
| GHSA-8gq9-2x98-w8hf protobuf-cpp and protobuf-python have potential Denial of Service issue |
High EPSS 1.51% |
>= 4.0.0, < 4.21.6 | 4.21.6 |
| GHSA-8gq9-2x98-w8hf protobuf-cpp and protobuf-python have potential Denial of Service issue |
High EPSS 1.51% |
>= 3.20.0, < 3.20.2 | 3.20.2 |
| PYSEC-2022-48 Withdrawn Advisory: NULL Pointer Dereference in Protocol Buffers |
High EPSS 2.66% |
< 3.15.0 | 3.15.0 |
| PYSEC-2022-48 Withdrawn Advisory: NULL Pointer Dereference in Protocol Buffers |
High EPSS 2.66% |
< 3.15.0 | 3.15.0 |
| PYSEC-2022-48 Withdrawn Advisory: NULL Pointer Dereference in Protocol Buffers |
High EPSS 2.66% |
< 3.15.0 | 3.15.0 |
| GHSA-jwvw-v7c5-m82h protobuf susceptible to buffer overflow |
High EPSS 4.96% |
< 3.4.0 | 3.4.0 |
| GHSA-jwvw-v7c5-m82h protobuf susceptible to buffer overflow |
High EPSS 4.96% |
< 3.4.0 | 3.4.0 |
| GHSA-jwvw-v7c5-m82h protobuf susceptible to buffer overflow |
High EPSS 4.96% |
< 3.4.0 | 3.4.0 |
| GHSA-jwvw-v7c5-m82h protobuf susceptible to buffer overflow |
High EPSS 4.96% |
< 3.1.0.post1 | 3.1.0.post1 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor