Skip to content

products-cmfplone (PyPI)

Advisories
18
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 5.1.0 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "products-cmfplone>=5.1.0"
poetry
poetry add "products-cmfplone>=5.1.0"
uv
uv add "products-cmfplone>=5.1.0"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-8g72-gq68-6gqh
Products.CMFPlone Open Redirect Vulnerability
Medium
EPSS 0.69%
>= 5.1a1, < 5.1.0
5.1.0
GHSA-8g72-gq68-6gqh
Products.CMFPlone Open Redirect Vulnerability
Medium
EPSS 0.69%
< 4.3.17
>= 5.0.0, < 5.0.10
>= 5.1a1, < 5.1.0
4.3.17
5.0.10
5.1.0
GHSA-859j-668v-mrr6
Products.CMFPlone XSS in profile home_page property
Medium
EPSS 0.56%
< 4.3.17
4.3.17
GHSA-859j-668v-mrr6
Products.CMFPlone XSS in profile home_page property
Medium
EPSS 0.56%
>= 5.0.0, < 5.0.10
5.0.10
GHSA-859j-668v-mrr6
Products.CMFPlone XSS in profile home_page property
Medium
EPSS 0.56%
>= 5.1a1, < 5.1.0
5.1.0
GHSA-859j-668v-mrr6
Products.CMFPlone XSS in profile home_page property
Medium
EPSS 0.56%
< 4.3.17
>= 5.0.0, < 5.0.10
>= 5.1a1, < 5.1.0
4.3.17
5.0.10
5.1.0
GHSA-8g72-gq68-6gqh
Products.CMFPlone Open Redirect Vulnerability
Medium
EPSS 0.69%
< 4.3.17
4.3.17
GHSA-8g72-gq68-6gqh
Products.CMFPlone Open Redirect Vulnerability
Medium
EPSS 0.69%
>= 5.0.0, < 5.0.10
5.0.10
GHSA-984m-rj28-8c6x
Plone unauthorized member addition vulnerability
Medium
EPSS 2.02%
>= 3.3.0, < 4.3.7
4.3.7
GHSA-984m-rj28-8c6x
Plone unauthorized member addition vulnerability
Medium
EPSS 2.02%
>= 3.3.0, < 4.3.7
>= 5.0a1, < 5.0rc2
4.3.7
5.0rc2
GHSA-984m-rj28-8c6x
Plone unauthorized member addition vulnerability
Medium
EPSS 2.02%
>= 5.0a1, < 5.0rc2
5.0rc2
GHSA-rg52-j87w-pf83
Plone Filesystem path information leak
Medium
EPSS 2.14%
>= 3.3, < 4.3.3
4.3.3
GHSA-4vr8-r7qr-fpvq
Plone Privilege escalation through exposed underlying API
Medium
EPSS 1.31%
>= 3.3, < 4.3.3
4.3.3
GHSA-rg52-j87w-pf83
Plone Filesystem path information leak
Medium
EPSS 2.14%
>= 3.3, < 4.3.3
4.3.3
GHSA-4vr8-r7qr-fpvq
Plone Privilege escalation through exposed underlying API
Medium
EPSS 1.31%
>= 3.3, < 4.3.3
4.3.3
GHSA-p7h9-vf92-5fj5
Cross-site scripting in Products.CMFPlone and Products.PasswordResetTool
Medium
EPSS 2.39%
< 4.0.7
>= 4.1a1, < 4.1rc3
4.0.7
4.1rc3
GHSA-p7h9-vf92-5fj5
Cross-site scripting in Products.CMFPlone and Products.PasswordResetTool
Medium
EPSS 2.39%
< 4.0.7
4.0.7
GHSA-p7h9-vf92-5fj5
Cross-site scripting in Products.CMFPlone and Products.PasswordResetTool
Medium
EPSS 2.39%
>= 4.1a1, < 4.1rc3
4.1rc3
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor