Skip to content

pgadmin4 (PyPI)

Advisories
56
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 9.15 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "pgadmin4>=9.15"
poetry
poetry add "pgadmin4>=9.15"
uv
uv add "pgadmin4>=9.15"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-hv9p-2pqf-r5w3
pgAdmin 4: Improper restriction of excessive authentication attempts
Medium
EPSS 0.21%
< 9.15
9.15
GHSA-hv9p-2pqf-r5w3
pgAdmin 4: Improper restriction of excessive authentication attempts
Medium
EPSS 0.21%
< 9.15
9.15
GHSA-hr4r-fwpv-c95j
pgAdmin 4 File Manager has symbolic-link path traversal
High
EPSS 0.33%
< 9.15
9.15
GHSA-hr4r-fwpv-c95j
pgAdmin 4 File Manager has symbolic-link path traversal
High
EPSS 0.33%
< 9.15
9.15
GHSA-4rhg-h8f2-v4jm
pgAdmin 4 has deserialization of untrusted data in its FileBackedSessionManager
High
EPSS 0.13%
< 9.15
9.15
GHSA-4rhg-h8f2-v4jm
pgAdmin 4 has deserialization of untrusted data in its FileBackedSessionManager
High
EPSS 0.13%
< 9.15
9.15
GHSA-p58c-q354-6c4f
pgAdmin 4 contains local file inclusion (LFI) and server-side request forgery (SSRF) vulnerabilities
Medium
EPSS 0.22%
< 9.15
9.15
GHSA-p58c-q354-6c4f
pgAdmin 4 contains local file inclusion (LFI) and server-side request forgery (SSRF) vulnerabilities
Medium
EPSS 0.22%
< 9.15
9.15
GHSA-j74f-g7vx-fh4x
pgAdmin 4: OS command injection vulnerability in Import/Export query export
High
EPSS 1.44%
< 9.15
9.15
GHSA-j74f-g7vx-fh4x
pgAdmin 4: OS command injection vulnerability in Import/Export query export
High
EPSS 1.44%
< 9.15
9.15
GHSA-hp84-p2gq-6fvr
SQL injection vulnerability in pgAdmin 4 Maintenance Tool
High
EPSS 0.46%
< 9.15
9.15
GHSA-hp84-p2gq-6fvr
SQL injection vulnerability in pgAdmin 4 Maintenance Tool
High
EPSS 0.46%
< 9.15
9.15
GHSA-6p2c-69cv-3fxq
pgAdmin 4: Stored cross-site scripting (XSS) vulnerability in Browser Tree and Explain Visualizer modules
Medium
EPSS 0.16%
< 9.15
9.15
GHSA-6p2c-69cv-3fxq
pgAdmin 4: Stored cross-site scripting (XSS) vulnerability in Browser Tree and Explain Visualizer modules
Medium
EPSS 0.16%
< 9.15
9.15
GHSA-h2x2-q2mc-24gw
pgAdmin 4 server mode has an authorization vulnerability affecting Server Groups, Servers, Shared Servers, Background Processes, and Debugger modules
Critical
EPSS 0.46%
< 9.15
9.15
GHSA-h2x2-q2mc-24gw
pgAdmin 4 server mode has an authorization vulnerability affecting Server Groups, Servers, Shared Servers, Background Processes, and Debugger modules
Critical
EPSS 0.46%
< 9.15
9.15
GHSA-3p7x-94q9-jq9x
pgadmin4 affected by a Restore restriction bypass via key disclosure vulnerability
Medium
EPSS 0.45%
< 9.12
9.12
GHSA-3p7x-94q9-jq9x
pgadmin4 affected by a Restore restriction bypass via key disclosure vulnerability
Medium
EPSS 0.45%
< 9.12
9.12
GHSA-fxmw-jcgr-w44v
pgadmin4 has a Meta-Command Filter Command Execution
High
EPSS 0.94%
< 9.11
9.11
GHSA-fxmw-jcgr-w44v
pgadmin4 has a Meta-Command Filter Command Execution
High
EPSS 0.94%
< 9.11
9.11
GHSA-g4r8-3qmh-pmch
pgAdmin has vulnerability in LDAP authentication mechanism that allows bypassing TLS certificate verification
High
EPSS 0.23%
< 9.10
9.10
GHSA-g4r8-3qmh-pmch
pgAdmin has vulnerability in LDAP authentication mechanism that allows bypassing TLS certificate verification
High
EPSS 0.23%
< 9.10
9.10
GHSA-cvf4-f829-762v
pgAdmin is affected by an LDAP injection vulnerability
High
EPSS 0.48%
< 9.10
9.10
GHSA-cvf4-f829-762v
pgAdmin is affected by an LDAP injection vulnerability
High
EPSS 0.48%
< 9.10
9.10
GHSA-rm79-x4g6-hvg5
pgAdmin 4 has command injection vulnerability on Windows systems
High
EPSS 0.91%
< 9.10
9.10
GHSA-rm79-x4g6-hvg5
pgAdmin 4 has command injection vulnerability on Windows systems
High
EPSS 0.91%
< 9.10
9.10
GHSA-w2p4-p4rh-qcm3
pgAdmin4 vulnerable to Remote Code Execution (RCE) when running in server mode
Critical
EPSS 12.71%
< 9.10
9.10
GHSA-w2p4-p4rh-qcm3
pgAdmin4 vulnerable to Remote Code Execution (RCE) when running in server mode
Critical
EPSS 12.71%
< 9.10
9.10
GHSA-6859-2qxq-ffv2
pgadmin4 is affected by a Cross-Origin Opener Policy (COOP) vulnerability
High
EPSS 0.23%
< 9.8
9.8
GHSA-6859-2qxq-ffv2
pgadmin4 is affected by a Cross-Origin Opener Policy (COOP) vulnerability
High
EPSS 0.23%
< 9.8
9.8
GHSA-2rrx-pphc-qfv9
pgAdmin 4 Vulnerable to Cross-Site Scripting (XSS) via Query Result Rendering
Medium
EPSS 0.33%
< 9.2
9.2
GHSA-2rrx-pphc-qfv9
pgAdmin 4 Vulnerable to Cross-Site Scripting (XSS) via Query Result Rendering
Medium
EPSS 0.33%
< 9.2
9.2
GHSA-g73c-fw68-pwx3
pgAdmin 4 Vulnerable to Remote Code Execution
High
EPSS 56.30%
< 9.2
9.2
GHSA-g73c-fw68-pwx3
pgAdmin 4 Vulnerable to Remote Code Execution
High
EPSS 56.30%
< 9.2
9.2
GHSA-7w6r-748w-mh52
pgAdmin has Incorrect Default Permissions
High
EPSS 0.45%
< 7.0
7.0
GHSA-7w6r-748w-mh52
pgAdmin has Incorrect Default Permissions
High
EPSS 0.45%
< 7.0
7.0
GHSA-jm9x-rx9x-wpqj
OAuth2 client ID and secret exposed through the web browser
Medium
EPSS 9.69%
< 8.12
8.12
GHSA-jm9x-rx9x-wpqj
OAuth2 client ID and secret exposed through the web browser
Medium
EPSS 9.69%
< 8.12
8.12
GHSA-xv64-8p4r-94gq
pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload
Medium
EPSS 0.46%
< 8.6
8.6
GHSA-xv64-8p4r-94gq
pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload
Medium
EPSS 0.46%
< 8.6
8.6
GHSA-2mvc-557g-5638
pgAdmin is affected by a multi-factor authentication bypass vulnerability
High
EPSS 0.63%
< 8.6
8.6
GHSA-2mvc-557g-5638
pgAdmin is affected by a multi-factor authentication bypass vulnerability
High
EPSS 0.63%
< 8.6
8.6
GHSA-27jx-ffw8-xrqv
pgAdmin Remote Code Execution (RCE) vulnerability
Critical
EPSS 65.81%
< 8.5
8.5
GHSA-27jx-ffw8-xrqv
pgAdmin Remote Code Execution (RCE) vulnerability
Critical
EPSS 65.81%
< 8.5
8.5
GHSA-rj98-crf4-g69w
pgAdmin 4 vulnerable to Unsafe Deserialization and Remote Code Execution by an Authenticated user
Critical
EPSS 79.47%
< 8.4
8.4
GHSA-rj98-crf4-g69w
pgAdmin 4 vulnerable to Unsafe Deserialization and Remote Code Execution by an Authenticated user
Critical
EPSS 79.47%
< 8.4
8.4
GHSA-ghp8-52vx-77j4
pgAdmin failed to properly control the server code
High
EPSS 1.78%
< 7.7
7.7
GHSA-ghp8-52vx-77j4
pgAdmin failed to properly control the server code
High
EPSS 1.78%
< 7.7
7.7
GHSA-9crj-hpxh-f6qg
pgAdmin 4 vulnerable to directory traversal
Medium
EPSS 8.83%
< 6.19
6.19
GHSA-9crj-hpxh-f6qg
pgAdmin 4 vulnerable to directory traversal
Medium
EPSS 8.83%
< 6.19
6.19
GHSA-894c-rg7f-3c62
pgAdmin 4 Open Redirect vulnerability
Medium
EPSS 0.96%
< 6.14
6.14
GHSA-894c-rg7f-3c62
pgAdmin 4 Open Redirect vulnerability
Medium
EPSS 0.96%
< 6.14
6.14
GHSA-3v6v-2x6p-32mc
pgadmin4 vulnerable to Code Injection
High
EPSS 80.07%
< 6.17
6.17
GHSA-3v6v-2x6p-32mc
pgadmin4 vulnerable to Code Injection
High
EPSS 80.07%
< 6.17
6.17
GHSA-cr8c-972v-rmp3
pgAdmin 4 Path Traversal vulnerability
Medium
EPSS 0.97%
< 6.7
6.7
GHSA-cr8c-972v-rmp3
pgAdmin 4 Path Traversal vulnerability
Medium
EPSS 0.97%
< 6.7
6.7
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor