Skip to content

opentelemetry-instrumentation (PyPI)

OpenTelemetry instrumentation for Python modules

Advisories
2
Latest version
0.66.0b1
Released Oct 6, 2026
License
Apache-2.0
OpenSSF Scorecard
7.4 / 10

How to fix

Upgrading to 0.41b0 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "opentelemetry-instrumentation>=0.66.0b1"
poetry
poetry add "opentelemetry-instrumentation>=0.66.0b1"
uv
uv add "opentelemetry-instrumentation>=0.66.0b1"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-5rv5-6h4r-h22v
opentelemetry-instrumentation Denial of Service vulnerability due to unbound cardinality metrics
High
EPSS 0.84%
< 0.41b0
0.41b0
GHSA-5rv5-6h4r-h22v
opentelemetry-instrumentation Denial of Service vulnerability due to unbound cardinality metrics
High
EPSS 0.84%
< 0.41b0
0.41b0

Source: https://github.com/open-telemetry/opentelemetry-python-contrib

Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor