docling-core (PyPI)
Advisories
3
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.48.4 or later clears every advisory below that has a fix.
Upgrade commands
pip
pip install --upgrade "docling-core>=2.48.4"poetry
poetry add "docling-core>=2.48.4"uv
uv add "docling-core>=2.48.4"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-vqxf-v2gg-x3hc docling-core vulnerable to Remote Code Execution via unsafe PyYAML usage |
Critical EPSS 1.53% |
>= 2.21.0, < 2.48.4 | 2.48.4 |
| GHSA-vqxf-v2gg-x3hc docling-core vulnerable to Remote Code Execution via unsafe PyYAML usage |
Critical EPSS 1.53% |
>= 2.21.0, < 2.48.4 | 2.48.4 |
| GHSA-vqxf-v2gg-x3hc docling-core vulnerable to Remote Code Execution via unsafe PyYAML usage |
Critical EPSS 1.53% |
>= 2.21.0, < 2.48.4 | 2.48.4 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor