Skip to content

cinder (PyPI)

Advisories
10
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 20.0.2 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "cinder>=20.0.2"
poetry
poetry add "cinder>=20.0.2"
uv
uv add "cinder>=20.0.2"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-r4v4-w9pv-6fph
OpenStack Cinder, Glance, and Nova vulnerable to arbitrary file access
Medium
EPSS 0.83%
<= 24.0.0
No fix yet
GHSA-r4v4-w9pv-6fph
OpenStack Cinder, Glance, and Nova vulnerable to arbitrary file access
Medium
EPSS 0.83%
<= 24.0.0
No fix yet
GHSA-7h75-hwxx-qpgc
OpenStack Cinder, glance, and Nova vulnerable to Path Traversal
Medium
EPSS 1.03%
< 19.1.2
>= 20.0.0, < 20.0.2
19.1.2
20.0.2
GHSA-7h75-hwxx-qpgc
OpenStack Cinder, glance, and Nova vulnerable to Path Traversal
Medium
EPSS 1.03%
< 19.1.2
19.1.2
GHSA-7h75-hwxx-qpgc
OpenStack Cinder, glance, and Nova vulnerable to Path Traversal
Medium
EPSS 1.03%
>= 20.0.0, < 20.0.2
20.0.2
GHSA-g2j5-7vgx-6xrx
OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption
High
EPSS 3.09%
< 7.0.2
>= 8.0.0, < 9.0.0
7.0.2
9.0.0
GHSA-g2j5-7vgx-6xrx
OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption
High
EPSS 3.09%
>= 8.0.0, < 9.0.0
9.0.0
GHSA-g2j5-7vgx-6xrx
OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption
High
EPSS 3.09%
< 7.0.2
7.0.2
GHSA-qh2x-hpf9-cf2g
OpenStack Keystone and other components vulnerable to Improper Certificate Validation
Medium
EPSS 0.97%
< 7.0.0a0
7.0.0a0
GHSA-qh2x-hpf9-cf2g
OpenStack Keystone and other components vulnerable to Improper Certificate Validation
Medium
EPSS 0.97%
< 7.0.0a0
7.0.0a0
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor