Skip to content

brotlicffi (PyPI)

Advisories
3
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 1.2.1.0 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "brotlicffi>=1.2.1.0"
poetry
poetry add "brotlicffi>=1.2.1.0"
uv
uv add "brotlicffi>=1.2.1.0"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Known exploited
Critical
EPSS 82.64%
>= 1.0.3, < 1.2.1.0
1.2.1.0
GHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Known exploited
Critical
EPSS 82.64%
>= 1.0.3, < 1.2.1.0
1.2.1.0
GHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Known exploited
Critical
EPSS 82.64%
< 1.2.1.0
1.2.1.0
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor