Skip to content

brotli (PyPI)

Advisories
5
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 1.2.1 or later clears every advisory below that has a fix.

Upgrade commands
pip
pip install --upgrade "brotli>=1.2.1"
poetry
poetry add "brotli>=1.2.1"
uv
uv add "brotli>=1.2.1"

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Known exploited
Critical
EPSS 82.64%
>= 1.0.3, < 1.2.1
1.2.1
GHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Known exploited
Critical
EPSS 82.64%
>= 1.0.3, < 1.2.1
1.2.1
GHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Known exploited
Critical
EPSS 82.64%
< 1.2.1
1.2.1
GHSA-5v8v-66v8-mwm7
Integer overflow in the bundled Brotli C library
Critical
EPSS 3.22%
< 1.0.8
1.0.8
GHSA-5v8v-66v8-mwm7
Integer overflow in the bundled Brotli C library
Critical
EPSS 3.22%
< 1.0.8
1.0.8
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor