apache-airflow-core (PyPI)
Advisories
6
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 3.2.0 or later clears every advisory below that has a fix.
Upgrade commands
pip
pip install --upgrade "apache-airflow-core>=3.2.0"poetry
poetry add "apache-airflow-core>=3.2.0"uv
uv add "apache-airflow-core>=3.2.0"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-w9r4-94fj-xp69 Apache Airflow Exposes Secrets in Variables Saved as JSON Dictionaries |
Low EPSS 0.42% |
>= 3.0.0, < 3.2.0 | 3.2.0 |
| GHSA-w9r4-94fj-xp69 Apache Airflow Exposes Secrets in Variables Saved as JSON Dictionaries |
Low EPSS 0.42% |
>= 3.0.0, < 3.2.0 | 3.2.0 |
| PYSEC-2026-18 Apache Airflow exposes SQL stack trace despite "api/expose_stack_traces" set to false |
High EPSS 0.45% |
< 3.2.0 | 3.2.0 |
| PYSEC-2026-18 Apache Airflow exposes SQL stack trace despite "api/expose_stack_traces" set to false |
High EPSS 0.45% |
< 3.2.0 | 3.2.0 |
| PYSEC-2026-13 Apache Airflow allows code execution through crafted XCom payloads |
High EPSS 0.82% |
< 3.2.0 | 3.2.0 |
| PYSEC-2026-13 Apache Airflow allows code execution through crafted XCom payloads |
High EPSS 0.82% |
< 3.2.0 | 3.2.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor