airflow (PyPI)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.10.3 or later clears every advisory below that has a fix.
Upgrade commands
pip
pip install --upgrade "airflow>=2.10.3"poetry
poetry add "airflow>=2.10.3"uv
uv add "airflow>=2.10.3"Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| PYSEC-2024-182 Apache Airflow: Sensitive configuration values are not masked in the logs by default |
High EPSS 1.34% |
< 2.10.3 | 2.10.3 |
| PYSEC-2024-182 Apache Airflow: Sensitive configuration values are not masked in the logs by default |
High EPSS 1.34% |
< 2.10.3 | 2.10.3 |
| PYSEC-2019-216 Apache Airflow vulnerable to XSS and local file disclosure |
Medium EPSS 1.28% |
< 1.10.6 | 1.10.6 |
| PYSEC-2019-216 Apache Airflow vulnerable to XSS and local file disclosure |
Medium EPSS 1.28% |
< 1.10.6 | 1.10.6 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor