dio_http2_adapter (Pub)
Advisories
1
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.8.0 or later clears every advisory below that has a fix.
Upgrade commands
dart
dart pub add dio_http2_adapter:^2.8.0Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-cr65-55v9-xhvv Dio: Cross-origin redirect leaks sensitive request headers in `dio_http2_adapter` |
High EPSS 0.36% |
>= 1.0.0, < 2.8.0 | 2.8.0 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor