archive (Pub)
Advisories
2
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 3.3.8 or later clears every advisory below that has a fix.
Upgrade commands
dart
dart pub add archive:^3.3.8Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-9v85-q87q-g4vg Path traversal in Archive |
High EPSS 0.37% |
< 3.3.8 | 3.3.8 |
| GHSA-r285-q736-9v95 Filename spoofing in archive |
High EPSS 0.35% |
< 3.3.8 | 3.3.8 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor