typo3/html-sanitizer (Packagist)
Advisories
4
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 2.1.1 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require typo3/html-sanitizer:^2.1.1Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-hvwx-qh2h-xcfj TYPO3 HTML Sanitizer vulnerable to Cross-Site Scripting |
Medium EPSS 0.47% |
>= 1.0.0, < 1.5.0 | 1.5.0 |
| GHSA-hvwx-qh2h-xcfj TYPO3 HTML Sanitizer vulnerable to Cross-Site Scripting |
Medium EPSS 0.47% |
>= 2.0.0, < 2.1.1 | 2.1.1 |
| GHSA-47m6-46mj-p235 TYPO3 HTML Sanitizer Bypasses Cross-Site Scripting Protection |
Medium EPSS 0.82% |
>= 1.0.0, < 1.0.7 | 1.0.7 |
| GHSA-47m6-46mj-p235 TYPO3 HTML Sanitizer Bypasses Cross-Site Scripting Protection |
Medium EPSS 0.82% |
>= 2.0.0, < 2.0.16 | 2.0.16 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor