symfony/validator (Packagist)
Advisories
7
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 7.1.4 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require symfony/validator:^7.1.4Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-g3rh-rrhp-jhh9 Symfony has an incorrect response from Validator when input ends with `\n` |
Low EPSS 0.46% |
< 5.4.43 | 5.4.43 |
| GHSA-g3rh-rrhp-jhh9 Symfony has an incorrect response from Validator when input ends with `\n` |
Low EPSS 0.46% |
>= 6.0.0, < 6.4.11 | 6.4.11 |
| GHSA-g3rh-rrhp-jhh9 Symfony has an incorrect response from Validator when input ends with `\n` |
Low EPSS 0.46% |
>= 7.0.0, < 7.1.4 | 7.1.4 |
| GHSA-q8j7-fjh7-25v5 Symfony collectionCascaded and collectionCascadedDeeply fields security bypass |
High EPSS 1.44% |
>= 2.0.0, < 2.0.24 | 2.0.24 |
| GHSA-q8j7-fjh7-25v5 Symfony collectionCascaded and collectionCascadedDeeply fields security bypass |
High EPSS 1.44% |
>= 2.3.0, < 2.3.3 | 2.3.3 |
| GHSA-q8j7-fjh7-25v5 Symfony collectionCascaded and collectionCascadedDeeply fields security bypass |
High EPSS 1.44% |
>= 2.1.0, < 2.1.12 | 2.1.12 |
| GHSA-q8j7-fjh7-25v5 Symfony collectionCascaded and collectionCascadedDeeply fields security bypass |
High EPSS 1.44% |
>= 2.2.0, < 2.2.5 | 2.2.5 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor