symfony/security-core (Packagist)
Advisories
15
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 5.2.8 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require symfony/security-core:^5.2.8Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-q87v-q8fw-gmj5 Symfony Incorrect Access Control |
Critical EPSS 1.85% |
>= 2.8.23, < 2.8.25 | 2.8.25 |
| GHSA-q87v-q8fw-gmj5 Symfony Incorrect Access Control |
Critical EPSS 1.85% |
>= 2.7.30, < 2.7.32 | 2.7.32 |
| GHSA-q87v-q8fw-gmj5 Symfony Incorrect Access Control |
Critical EPSS 1.85% |
>= 3.3.3, < 3.3.5 | 3.3.5 |
| GHSA-q87v-q8fw-gmj5 Symfony Incorrect Access Control |
Critical EPSS 1.85% |
>= 3.2.10, < 3.2.12 | 3.2.12 |
| GHSA-jjx5-fq5g-8xpc Symfony Cryptographic Vulnerability |
High EPSS 1.91% |
>= 2.4.0, < 2.6.13 | 2.6.13 |
| GHSA-jjx5-fq5g-8xpc Symfony Cryptographic Vulnerability |
High EPSS 1.91% |
>= 2.7.0, < 2.7.9 | 2.7.9 |
| GHSA-35c5-28pg-2qg4 Symfony Authentication Bypass |
Critical EPSS 2.37% |
>= 2.8.0, < 2.8.37 | 2.8.37 |
| GHSA-35c5-28pg-2qg4 Symfony Authentication Bypass |
Critical EPSS 2.37% |
>= 3.0.0, < 3.3.17 | 3.3.17 |
| GHSA-35c5-28pg-2qg4 Symfony Authentication Bypass |
Critical EPSS 2.37% |
>= 3.4.0, < 3.4.7 | 3.4.7 |
| GHSA-35c5-28pg-2qg4 Symfony Authentication Bypass |
Critical EPSS 2.37% |
>= 4.0.0, < 4.0.7 | 4.0.7 |
| GHSA-wvj5-r78r-hhfq Symfony Authentication Bypass |
Critical EPSS 4.29% |
>= 2.8.0, < 2.8.6 | 2.8.6 |
| GHSA-wvj5-r78r-hhfq Symfony Authentication Bypass |
Critical EPSS 4.29% |
>= 3.0.0, < 3.0.6 | 3.0.6 |
| GHSA-5pv8-ppvj-4h68 Prevent user enumeration using Guard or the new Authenticator-based Security |
Medium EPSS 1.64% |
>= 5.0.0, < 5.2.8 | 5.2.8 |
| GHSA-5pv8-ppvj-4h68 Prevent user enumeration using Guard or the new Authenticator-based Security |
Medium EPSS 1.64% |
>= 4.0.0, < 4.4.23 | 4.4.23 |
| GHSA-5pv8-ppvj-4h68 Prevent user enumeration using Guard or the new Authenticator-based Security |
Medium EPSS 1.64% |
>= 2.8.0, < 3.4.48 | 3.4.48 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor