symfony/security-bundle (Packagist)
Advisories
19
Latest version
—
License
—
OpenSSF Scorecard
—
How to fix
Upgrading to 7.1.3 or later clears every advisory below that has a fix.
Upgrade commands
composer
composer require symfony/security-bundle:^7.1.3Known vulnerabilities
| Advisory | Severity | Affected | Fixed in |
|---|---|---|---|
| GHSA-jxgr-3v7q-3w9v Symfony's `Security::login` does not take into account custom `user_checker` |
Low EPSS 0.31% |
>= 7.1.0, < 7.1.3 | 7.1.3 |
| GHSA-jxgr-3v7q-3w9v Symfony's `Security::login` does not take into account custom `user_checker` |
Low EPSS 0.31% |
>= 7.0.0, < 7.0.10 | 7.0.10 |
| GHSA-jxgr-3v7q-3w9v Symfony's `Security::login` does not take into account custom `user_checker` |
Low EPSS 0.31% |
>= 6.2.0, < 6.4.10 | 6.4.10 |
| GHSA-3gv2-29qc-v67m Symfony vulnerable to Session Fixation of CSRF tokens |
Medium EPSS 0.79% |
>= 6.1.0, < 6.1.12 | 6.1.12 |
| GHSA-3gv2-29qc-v67m Symfony vulnerable to Session Fixation of CSRF tokens |
Medium EPSS 0.79% |
>= 6.2.0, < 6.2.6 | 6.2.6 |
| GHSA-3gv2-29qc-v67m Symfony vulnerable to Session Fixation of CSRF tokens |
Medium EPSS 0.79% |
>= 2.0.0, < 4.4.50 | 4.4.50 |
| GHSA-3gv2-29qc-v67m Symfony vulnerable to Session Fixation of CSRF tokens |
Medium EPSS 0.79% |
>= 5.0.0, < 5.4.20 | 5.4.20 |
| GHSA-3gv2-29qc-v67m Symfony vulnerable to Session Fixation of CSRF tokens |
Medium EPSS 0.79% |
>= 6.0.0, < 6.0.20 | 6.0.20 |
| GHSA-7hwc-2cq4-6x2w Symfony Open Redirect |
Medium EPSS 1.12% |
>= 3.4.0, < 3.4.11 | 3.4.11 |
| GHSA-7hwc-2cq4-6x2w Symfony Open Redirect |
Medium EPSS 1.12% |
>= 4.0.0, < 4.0.11 | 4.0.11 |
| GHSA-7hwc-2cq4-6x2w Symfony Open Redirect |
Medium EPSS 1.12% |
>= 3.3.0, < 3.3.17 | 3.3.17 |
| GHSA-7hwc-2cq4-6x2w Symfony Open Redirect |
Medium EPSS 1.12% |
>= 2.8.0, < 2.8.41 | 2.8.41 |
| GHSA-7hwc-2cq4-6x2w Symfony Open Redirect |
Medium EPSS 1.12% |
>= 2.7.0, < 2.7.48 | 2.7.48 |
| GHSA-g4g7-q726-v5hg Symfony CSRF Token Fixation |
High EPSS 0.75% |
>= 3.4.0, < 3.4.11 | 3.4.11 |
| GHSA-g4g7-q726-v5hg Symfony CSRF Token Fixation |
High EPSS 0.75% |
>= 4.0.0, < 4.0.11 | 4.0.11 |
| GHSA-g4g7-q726-v5hg Symfony CSRF Token Fixation |
High EPSS 0.75% |
>= 2.7.0, < 2.7.48 | 2.7.48 |
| GHSA-g4g7-q726-v5hg Symfony CSRF Token Fixation |
High EPSS 0.75% |
>= 2.8.0, < 2.8.41 | 2.8.41 |
| GHSA-g4g7-q726-v5hg Symfony CSRF Token Fixation |
High EPSS 0.75% |
>= 3.0.0, < 3.3.17 | 3.3.17 |
| GHSA-qw36-p97w-vcqr Cookie persistence after password changes in symfony/security-bundle |
Medium EPSS 1.32% |
>= 5.3.0, < 5.3.12 | 5.3.12 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor