Skip to content

symfony/runtime (Packagist)

Advisories
7
Latest version
—
License
—
OpenSSF Scorecard
—

How to fix

Upgrading to 8.0.12 or later clears every advisory below that has a fix.

Upgrade commands
composer
composer require symfony/runtime:^8.0.12

Known vulnerabilities

AdvisorySeverityAffectedFixed in
GHSA-fqc7-9xjw-jrh3
SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch
Critical
EPSS 0.72%
>= 5.4.46, < 5.4.52
5.4.52
GHSA-fqc7-9xjw-jrh3
SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch
Critical
EPSS 0.72%
>= 6.4.14, < 6.4.40
6.4.40
GHSA-fqc7-9xjw-jrh3
SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch
Critical
EPSS 0.72%
>= 7.1.7, < 7.4.12
7.4.12
GHSA-fqc7-9xjw-jrh3
SymfonyRuntime CVE-2024-50340 Patch Bypass: Web Requests Can Still Set APP_ENV/APP_DEBUG via parse_str/SAPI Argv Mismatch
Critical
EPSS 0.72%
>= 8.0.0, < 8.0.12
8.0.12
GHSA-x8vp-gf4q-mw5j
Symfony allows changing the environment through a query
High
EPSS 61.83%
>= 6.0.0, < 6.4.14
6.4.14
GHSA-x8vp-gf4q-mw5j
Symfony allows changing the environment through a query
High
EPSS 61.83%
>= 7.0.0, < 7.1.7
7.1.7
GHSA-x8vp-gf4q-mw5j
Symfony allows changing the environment through a query
High
EPSS 61.83%
>= 5.3.0, < 5.4.46
5.4.46
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor